Please Help!

  • I am currently trying to fix whatever I did to my Archive. I changed something inside of the admin panel and I have no idea what I did, or how to fix it (I’m new to wordpress).
    I want to list it all by month, and I have the admin control panel set up to archive monthly, and I have inserted –
    <?php get_archives() ?>
    My Problem is, that is is howing all my monthly archives like this –
    5 2004
    5 2003
    I want it to show up like
    May 2004
    April 2004
    March 2004
    Febuary 2004
    January 2004
    December 2003
    I have posted this before, and the person who replied told me to put in the folling code:
    <?php wp_get_archives(‘type=monthly’); ?>
    When I use that I get the following error:
    Fatal error: Call to undefined function: wp_get_archives() in /home2/earlyfro/public_html/index.php on line 95
    Line 95 would be the code that I was given to fix my problem…
    Thank you for taking the time to help me out…
    my url is – http://www.early-frost.org

Viewing 6 replies - 1 through 6 (of 6 total)
  • <?php wp_get_archives(‘type=monthly’); ?>
    is what it should be in WordPress 1.2. From the looks of it, it sounds like you have an earlier version.
    Mark’s way should work. Another way you can do it is change the default settings of the blog to make archives Monthly. So when you use <?php get_archives( ); ?> it will default to monthly. 🙂

    Thank so much for the reply, though I forgot to mention what version I am using … that would have helped alot!
    I have version – 1.0.1
    I have changed the admin settings so then it says –
    “Other Options”
    Posts per page – 20
    What to show – posts
    Archive mode – Monthly
    Time Differance – 0
    Date format – n/j/Y
    Time Format – g:i a
    Humm.. this is frustating..
    also when I change over to useing a calandar mode for arvhives … it does’nt list the month, only says 2004 and then on the link back it says (on the mouse over) – “View Posts for (appears to be two spaces) 2004”
    Humm… any other thoughts to help me out?

    submo, maybe you can use this as an excuse to upgrade wo 1.2. That should take less than 10 minutes.

    Sure thing! 🙂
    Is it very difficult? will I lose anything??
    Is there just an upgrade file or files to include? or do I have to do a complete re-install…

    I figured out the problem, though I dont know exactly what the problem is..
    The layout I am using, was causing the months not to show up, it works perfectly fine when I use the index file that comes with wordpress…
    When I put in my layout that I am wanting to use, it does’nt show the month… so werid… but I have upgraded to the newest version of wordpress…
    Another quick question…
    I used B2 for a little while before going over to wordpress, I had installed some hacks would those still work with wordpress or do I need to install the one for wordpress… I had installed – smilies and commenter pluging.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Please Help!’ is closed to new replies.