Support » How-To and Troubleshooting » Please help…

Please help…

  • No matter what I do, I cannot shake this problem =( Okay, I had previously installed wordpress but decided not to use it, so I deleted the files but I forgot to go and delete the databases. So, this time, when I went to go install everything, I got this error:
    Database error: [Table ‘wp_posts’ already exists]
    CREATE TABLE wp_posts ( ID int(10) unsigned NOT NULL auto_increment, post_author int(4) NOT NULL default ‘0’, post_date datetime NOT NULL default ‘0000-00-00 00:00:00’, post_date_gmt datetime NOT NULL default ‘0000-00-00 00:00:00’, post_content text NOT NULL, post_title text NOT NULL, post_category int(4) NOT NULL default ‘0’, post_excerpt text NOT NULL, post_lat float, post_lon float, post_status enum(‘publish’,’draft’,’private’) NOT NULL default ‘publish’, comment_status enum(‘open’,’closed’) NOT NULL default ‘open’, ping_status enum(‘open’,’closed’) NOT NULL default ‘open’, post_password varchar(20) NOT NULL default ”, post_name varchar(200) NOT NULL default ”, to_ping text NOT NULL, pinged text NOT NULL, post_modified datetime NOT NULL default ‘0000-00-00 00:00:00’, post_modified_gmt datetime NOT NULL default ‘0000-00-00 00:00:00’, post_content_filtered text NOT NULL, PRIMARY KEY (ID), KEY post_date (post_date), KEY post_date_gmt (post_date_gmt), KEY post_name (post_name), KEY post_status (post_status) )
    Now, I went back and deleted all the wp_ tables and all the wordpress files, edited the config file so the table name was “blog_” instead of “wp_”, then uploaded everything and I got the same thing [except instead of “Table ‘wp_posts'” it was “Table ‘blog_posts'”] even though I KNOW they weren’t there before…what should I do?? =T Everything shows up fine on my site, but now I can’t log in without the password that’s randomly generated…
    Some please, pretty please help?? =(

Viewing 8 replies - 1 through 8 (of 8 total)
  • The tables:
    I would actually delete the entire database and start again from scratch – there should be a way on your cpanel to do this.
    Password problems – not that you’ll need this if you start over:

    O_O Ugh…I would do that, but the database has other stuff and I’d rather keep it organized, I’ll try the phpMyAdmin thing, if it doesn’t work, I’ll make a new database. THank you SOOOOOOOOO much for the help!!! =D

    When I say delete the database, I don’t mean to wipe the whole mysql clean !
    When you set up wp, you gave it the name of a specific database within mysql. You should be able to delete that specific item and leave the rest of your databases intact.

    Mmhmm, I know =) I tried everything though…I tried making a new database, I tried deleting all the tables and trying to re-install…arrrg..I’m *still* getting the same error…and when I tried to re-set the password, it kept going to example.com/wp-admin/post.php >_< Any ideas?

    The new database does need to actually be set up in mysql. WP will do the tables. It will not create a db itself, nor allocate a user for it.

    Yes I know, that’s how I set it up before…in the control panel using MySQL.

    This type of thread can become unruly without a bit more info from you. There are a lot of variables. Could you please tell us as much about the installation environment as poss. There are some hosts that add a prefix to a db anyway. Are you on Linux or windows? What php v is installed? What mysql?. Sorry but with this type of error we need to go geeky. It is prolly a hosting issue.

    No no! Any help at all is appreciated! I’m sorry I’m such a newbie >_< Um, I’m using a Linux server, hostrocket…I’ve already contacted my host and I thought it was Low rated issue, but according to an email I’ve gotten, they’ve upgraded the problem to a more urgent concern…but they didn’t say if it was immediate, high, or medium. Um…I’m using PHP Version 4.3.7 and MySQL Version 4.0.18-standard…and Path to Perl /usr/bin/perl…does that help any? And yep, when I create a new database, the prefix is dejecte_DBNAME…Hm..oh! And I also tried to install b2evolution and b2 and I got the same issues. I hope that helps a little more =( Sorry for being so broad.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Please help…’ is closed to new replies.