Support » Plugin: Yoast SEO » [Please Help Me] Tag Feed are indexing on google ! how to stop it ?

  • Resolved yemafu

    (@yemafu)


    Plz Help me guys
    I am using yoast seo plugin and already set tag nonindex in yoast settings but my posts tag feed are indexing on google. How to stop it
    Tag are indexing like this: site dot com/tag/health/feed

    • This topic was modified 1 month, 2 weeks ago by yemafu.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support devnihil

    (@devnihil)

    @yemafu Can you please provide us with an example URL of one the URLs so that we can check whether the noindex metatag is being output correctly?

    You can also check this by viewing the source code of one of the tag pages and checking for the noindex tag.

    There are a number of ways you can set pages to noindex, so we would recommend checking all of them. You can check this setting by performing the following actions:

      • Go to the Edit screen for a tag
      • Scroll down to the Yoast metabox
      • Click on the ‘Advanced’ area
      • For ‘Allow search engines to show this tag in search results?’ make sure this is set to ‘No’
      * Note (setting this value to Yes will set meta robots to index and setting No would set meta robots to noindex)

    In addition, you can set tags to be indexed by performing the following actions:

      • In WordPress go to SEO>Search Appearance>Taxonomies
      • For Tags/strong> set ‘Show Tags in search results’ to ‘No’
      • Click ‘Save Changes’

    We also have a guide on how to set a tag to noindex here: https://yoast.com/help/how-do-i-noindex-urls/

    Thread Starter yemafu

    (@yemafu)

    Hello sir, my permalinks are like this https:// site .com/mypost.html
    also i have checked the source code of tag pages are noindex and also i set tags are noindex in yoast settings.

    but my feed pages are indexing on google. any idea to block feed indexing on google.

    indexes feed are like this:
    site .com/tag/healts/feed
    site .com/tag/health-care/feed
    site .com/mypost-title.html/feed

    plz help me to block feed indexing on google

    Thread Starter yemafu

    (@yemafu)

    please check this screenshot. yoast generating rss feed https://prnt.sc/wskss2

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand that Google is showing the /feed in the search results which you don’t wish to see. Yoast SEO doesn’t generate the /feed but WordPress itself does. However, Google still shouldn’t show the /feed in the search results for you.

    To disable the /feed indexing and showing them in the search results, you can add the noindex robots in the HTTP header of the /feed URL. Unfortunately, the Yoast SEO plugin has no such feature for this. So, you may want to either use a 3rd party plugin or manually implement such code on your site.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.