WordPress.org

Support

Support » Plugins and Hacks » Please fix a code

Please fix a code

  • Today I was download your plugin. It is great, but I have found one bug.
    In file loginForm.php, at the end, there is something like this:

    ?>(newline)
    (newline)
    (newline)

    And in some cases(with some other plugins…etc) it make an problem. If any plugin or wordpress try to redirect me, I get blank page with this error:

    Warning: Cannot modify header information – headers already sent by (output started at /path/to/the/project/wp-content/plugins/front-end-login-form/loginForm.php:212) in /path/to/the/project/wp-includes/pluggable.php on line 876

    The solution is remove newlines and empty symbols after end of PHP code, after ?>

    http://wordpress.org/extend/plugins/front-end-login-form/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Is there a solution yet? I’m still getting the same issue.

    I also had the same problem. This also caused XML feeds to break on the WordPress site I was working on as the XML declaration had a blank line above it.

    Is this plugin compatible with latest wordpress?

    Is this plugin compatible with latest wordpress?

    It has been working fine for me save the whitespace issue mentioned above that breaks feeds.

    Scott

    it doesn t work even after whitespace issue
    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/themes/pagelines/header.php:26) in /wp-includes/pluggable.php on line 680

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Please fix a code’ is closed to new replies.