Support » Plugin: Custom Icons for Elementor » Please fix

  • Resolved Zexler

    (@zexler)


    Hello!

    Installed the plugin, and it does not work. Constantly there are errors, then in js, then in php.

    JS:
    uncaught TypeError: Failed to execute ‘readAsDataURL’ on ‘FileReader’: parameter 1 is not of type ‘Blob’.

    PHP:
    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/custom-icons-for-elementor/includes/template.options.page.php on line 196

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Michael Bourne

    (@michaelbourne)

    Are you uploading a .zip file that was generated and downloaded from Fontello.com?

    Yes, and also from Flaticon.

    Plugin Author Michael Bourne

    (@michaelbourne)

    Can you email me an admin login to test for myself? I can’t replicate it locally, or on any other install I have access to. michael @ michaelbourne.ca

    Ок, sent to your mail access. You can do anything, I made a backup.

    • This reply was modified 11 months, 1 week ago by  Zexler.
    Plugin Author Michael Bourne

    (@michaelbourne)

    Fixed via email, closing topic.

    I have found the cause of the issue. There are 2 things that you need to fix:

    1: Update the URL using any url replacement tool i.e., replace https://previewwebsite.com to https://productionwebsite.com

    2: Update the directory path: i.e, /home/preview/public_html to /home/production/public_html

    Then, Go To “Elementor” >> “Custom Icons” and click big “Regenerate” button.

    Note: all the URLs and paths I have mentioned are strictly depend on your own website and the server specif path. I have used the sample paths/URLs for the demonstration purpose only.

    @michaelbourne: I would suggest you to please use this instruction in your plugin’s main page. or if you can create a video for the same that would be great.

    Thanks,
    Sourabh

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Please fix’ is closed to new replies.