Support » Plugin: WooCommerce Stripe Payment Gateway » Please enter your card details to make a payment.

  • Resolved yuk1i

    (@yuk1i)


    Hello, I have a trouble. I have Stripe plugin and when I’m trying to buy my product on test mode (I tried and on live mode) I get this message: “Please enter your card details to make a payment. Developers: Please make sure that you are including jQuery and there are no JavaScript errors on the page.”

    I’m newbie on WordPress, so I very want that you help me. Thank you very much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Someone can help me?! :\

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hello there,

    This can often be caused by a plugin or theme conflict, so please start by troubleshooting those possibilities. Try switching to a default WordPress theme(like 2016) to see if it works.

    Then disabling non-WooCommerce plugins when testing this. If it works fine with plugins disabled, re-enable them one at a time until you can determine which plugin is causing the problem.

    Best regards,

    I was having a similar problem, and it turns out that the payment form wouldn’t work if it was located outside of the order review block.

    Make sure that your theme’s functions.php file doesn’t move the payment form with something like:

    remove_action( 'woocommerce_checkout_order_review', 'woocommerce_checkout_payment', 20 );
    add_action( 'woocommerce_after_order_notes', 'woocommerce_checkout_payment', 20 );
    • This reply was modified 3 years, 1 month ago by avishaiw.

    Sorry to jump back into an old topic, but I found this thread when looking for a solution to the same problem. You actually can move the payment form, the critical thing is that your payment form remains wrapped in some very specific ids and classes that Stripe’s JavaScript uses to parse the page:

    <div id="order_review" class="woocommerce-checkout-review-order"></div>

    As long as your form is wrapped in those tags, you shouldn’t get the referenced error anymore.

    Spent two days troubleshooting to figure out that my publishable and secret keys for the Stripe gateway in Woocommerce settings were entered incorrectly. When I enabled Strip Checkout, I got the error that pointed me to the right issue. In Stripe, PK is first, then SK, but WC has these fields switched. Just have to pay attention to the details. Good times.

    Thanks malechitech … You just saved me two days 🙂

    @amsoell I agree I believe that that is the issue but what is weird is that if I am logged in as an Admin I can place orders without any issues. I’m going to check the Stripe source code to see if there’s some sort of exclusion for admin WordPress accounts…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Please enter your card details to make a payment.’ is closed to new replies.