Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Please enter no more than …. characters.

  • Resolved schuerich

    (@schuerich)


    Please enter no more than …. characters.

    and

    Warning: No message defined for email-1

    No such string in POT and PO. Missing string for error messages!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @schuerich

    I hope you are doing well.

    I found both messages on a JavaScript file, but I can’t see how to trigger it on the front end to replicate the warnings.

    Could you let us know on which front end location you see it?

    Best Regards
    Patrick Freitas

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @schuerich

    Our developers also tried to replicate without avail though.
    They think there is a conflict with another JS validate rules.
    Could you please try to set the max characters/custom the validate message on field input/textarea/email, this might help to overwrite the validate rules:
    https://monosnap.com/file/rQMD1fv0e2lLNYsCYVmG4BIZK1tQEz
    https://monosnap.com/file/yC2IIZSDl9HtScvuGTndGMumadvPWP

    If this doesn’t help, then please proceed with a full conflict test, just to ensure that there isn’t anything else affecting this.
    How to:
    First, create a recent backup in case you lose any settings during the test and have to restore to a previous working state.
    Then deactivate all plugins apart from Forminator, activate a default theme like TwentyTwenty, clear all caches, and check again if the issue is still there. If not, it means that something is conflicting, so start activating the remaining plugins and theme, one by one this time, checking every time for the reported issue, until you reproduce the issue, thus finding the conflicted combination. The following flowchart image can assist you during this test: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    If this is a live website with traffic, I’d rather advise to create a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site.

    Warm regards,
    Dimitris

    Thread Starter schuerich

    (@schuerich)

    Could you please try to set the max characters/custom the validate message on field input/textarea/email, this might help to overwrite the validate rules:

    This does not solve the problem because the user can always enter 1 more character and the message appears. It is not known what other messages may be visible and come from JS.

    There is no such strings in forminator.pot. There are no such strings in the plugin settings. It is possible that this applies to more messages generated via JS, but it looks like you forgot about these translations. It’s hard to talk about any conflict since the strings are 100% untranslated.

    • This reply was modified 7 months, 1 week ago by schuerich.
    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @schuerich,

    Can you tell us which fields exactly are you using that are showing these errors?

    Also, could you export your form in question by going to Formiantor > Forms panel, click on a Gear icon next to your form and you will see the export option there.
    Upload the export file to any file sharing service like GDrive or DropBox and share the download link here so we can check this further on our end.

    Cheers,
    Predrag

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @schuerich ,

    We haven’t heard from you in a while now – it seems that you were able to solve this problem.

    If not, please don’t hesitate to reach out to us again and re-open this ticket.

    kind regards,
    Kasia

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Please enter no more than …. characters.’ is closed to new replies.