Support » Plugin: Disable Embeds » Please Disable Self-Domain Embeds

  • Resolved Jeff Starr

    (@specialk)


    Hey thanks for this plugin, I use it on all of my sites.

    I have a request, please disable self-domain embeds. Currently they are not disabled. For example, if your site domain is example.com, and within any post or page you include a link such as:

    https://example.com/some-other-published-post/

    The result (with your plugin active) will be this output HTML:

    <blockquote class="wp-embedded-content" data-secret="eCcoDo7d81"><p><a href="https://example.com/some-other-published-post/">1</a></p></blockquote>
    <iframe title="“1” — Example" class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://example.com/some-other-published-post/embed/#?secret=eCcoDo7d81" data-secret="eCcoDo7d81" width="600" height="338" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe>

    Please add a way to stop this from happening if possible. Also if it helps, I’ve been using this plugin for a long time and never have noticed any self-domain embeds happening anywhere. Then suddenly I am noticing them on latest WP version 5.2.2.

    Thanks again for this essential plugin, I hope you can provide a solution.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Hi there

    I cannot reproduce this. The plugin actually disables self-embeds. You might have run into a situation where the embed code was already cached by WordPress.

    Please try again by creating two new posts, and then past the URL of post 1 in the content of post 2. You should get an error saying “Sorry, this content could not be embedded.”

    If that doesn’t happen for you, there is something else going on on your site and I’d suggest opening an issue on GitHub so we can further debug this.

    This issue is not resolved, please give me some time to reproduce the issue and report back. Sorry I do not use Github, will keep discussion posted here at WordPress.org. Thanks.

    • This reply was modified 8 months, 1 week ago by Jeff Starr.

    Nevermind. The issue seems to have resolved itself since my original post a month ago. Sorry for wasting your time.

    • This reply was modified 8 months, 1 week ago by Jeff Starr.
    Plugin Author Pascal Birchler

    (@swissspidy)

    No worries, thanks for double checking!

    Jeff Starr

    (@specialk)

    Here is an example where your plugin is not working:

    https://perishablepress.com/wordpress-infinite-duplicate-content/

    If you inspect the first several pre elements, you will see the embeds. This is with your plugin enabled.

    I will leave the post as-is for awhile, but eventually will need to resolve the issue. Hopefully you get a chance to take a look.

    • This reply was modified 4 months ago by Jeff Starr.
    • This reply was modified 4 months ago by Jeff Starr.

    Update: tried waiting for about a week then had to resolve the issue locally by modifying the contents of the pre tag.

    Plugin Author Pascal Birchler

    (@swissspidy)

    I’m afraid I didn’t get a notification for your previous message.

    It is unclear to me whether you activated the plugin after adding the embeds or not. As mentioned before, WordPress caches oEmbed responses. Just activating the plugin won’t clear the cache.

    I also mentioned that I was unable to reproduce the issue. I would greatly appreciate if you could open an issue over at https://github.com/swissspidy/disable-embeds with steps on how this issue can be replicated on a clean WordPress install. Hope this makes sense to you.

    Thanks but no worries, I’ve found an alternate solution.

    @specialk

    Hi Jeff,
    I’m facing the same problem. If you don’t mind, can you share your solution here? Thank you.

    @elski it was some custom code to replace the plugin. Also made sure to avoid any code snippets that include the single URL as explained in my initial post above.

    @specialk noted, thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.