WordPress.org

Forums

[resolved] Please Anyone Help! Original WordPress Installation Deleted! (5 posts)

  1. KindtrEpreNeur
    Member
    Posted 2 years ago #

    My WordPress site was installed via Softaculous since I'm a newbie. What I did, I cloned (mysite.com/wp) the site to test out a theme but in the process I accidentally deleted the original installation (mysite.com). Now I'm left with the mysite.com/wp then I tried to remove the wp from the clone installation but I only got something like cgi-bin,wp etc on the white screen. I don't know what to do. Is there a simple guide I could follow please to get the site back again.

  2. RossMitchell
    Member
    Posted 2 years ago #

    First backup your wordpress datatbase.

    If you can find the copy of the wordpress file, then copy them back, if you can't the the easiest solution would be to start again. You will be able to dig much of your work setting up the initial site out of the database backup SQL file.

    Otherwise if you want to restore your site, then you will need to install all of the wordpress files, download the ZIP file, and upload them.
    Then you will have to re-create your wp-config.php file, use myPhpAdmin to recover the name of the database, also the database user, and then create a new password for that user, all of these details go into your wp-config.php file.

    The online guides will show you how to do lots of these steps, unfortunately though you will have to workout the details yourself. If you need further support, plesse reply here with what you see and find, what you did and what happened.

  3. KindtrEpreNeur
    Member
    Posted 2 years ago #

    I have a back up though generated on the 1st of July. It looks like back up-thedate-then .tar. I dont know I think I need to start over again..:-(

  4. KindtrEpreNeur
    Member
    Posted 2 years ago #

    I can't believe how easy the fix was. I figured it myself thinking all night what to do. Then it hit me. I recreated another clone but this time I remove the wp(the previous clone (mysite.com/wp) still exists of course) then the website I created with the theme showed up! Yes!

  5. KindtrEpreNeur
    Member
    Posted 2 years ago #

    I can't believe how easy the fix was. I figured it out my self thinking all night. Then it hit me. I recreated another clone out of the existing clone(mysite.com/wp)then I remove the wp extension to make it look like a normal domain. (mysite.com) Then lo and behold the website with the theme I wanted to have showed up right in front of me. YES!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.