Support » Requests and Feedback » Please allow to select version to update plugins

  • someone900

    (@someone900)


    Currently If I choose to update plugins I am forced to update to the latest plugin version.

    You by that assume that most users always update the plugin regularly. This is a false assumptions.

    WordPress is also used by corporations. Corporations don’t update to the most recent version but to the last known stable version.

    For example in my case I did extensive tests on a selected version. When I choose to update my production wordpress I saw that this version is no longer available but only a newer version. Hours of testing were lost. In my case the change between this two version is so big so that I have to restart the whole testing process.

    Please allow the user to choose the version of plugin he wants to update to.
    Some of us can be happy with not the most recent version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator cubecolour

    (@numeeja)


    ɹoʇɐɹǝpoɯ


    To do this you would need to install the required version of the plugin by ftp.

    Previous versions of plugins are available to download from the developers tab of the plugin page.

    someone900

    (@someone900)


    I am aware of that 🙂
    I suggest that this feature will be available in WordPress itself.

    In the update page add option to choose the version and update according to the user choice.

    WordPress can’t because developers don’t actually use semantic versioning universally :/ Some versions are absolutely weird names and wouldn’t help you at all.

    and why word press can’t force them to?
    Word Press can evolve, even if such ability isn’t available today.

    May i also note that even in the update of word press itself I can not choose version.
    It forces me to update to the most recent one… So maybe we can start there?
    And for this there is a perfectly good reason. For example if I’m running word press 4.2 I can only upgrade to 4.7 but what if I have a plugin that supports only till 4.6? Then 4.6 is the most logical choice for me.

    • This reply was modified 3 weeks, 1 day ago by  someone900.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.