Support » Requests and Feedback » Please Add Support for Older PHP Back to WP-CLI

  • timkite

    (@timkite)



    This may be a long shot, but any chance of adding support for older versions of PHP back to WP-CLI? Otherwise I’m stuck on 1.5.1 until I can move off RHEL6.

    Background: Enterprise Linux locks the version of most packages (including PHP) at the version the RHEL release ships with. For RHEL6, that’s PHP 5.3.3. Red Hat back-ports all relevant security fixes for all these packages as long as that release is supported, so I’ll have security updates for PHP 5.3.3 all the way into 2020 (and may need it…I have lots of sites to migrate).

    RHEL does not make it easy (or safe) to install newer PHP. In 6 there are basically no options other than testing/maintaining it ourselves from source (which my team doesn’t have time for). In 7, which is locked to PHP 5.4.16 and supported through 2024, there are Software Collections, but those are usually late to update. That means you get newer PHP, but you’re behind on security updates. And before anyone asks, our only distro option is RHEL.

    Is there any hope of getting this fixed? Or, alternatively, anyone planning back-porting fixes into WP-CLI 1.5.1 as WordPress core changes over time?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.