WordPress.org

Forums

Soundy Background Music
[resolved] Play/Pause Button Not Responding (19 posts)

  1. mhknuckles
    Member
    Posted 1 year ago #

    Hi. Love the pluggin. The play/pause button does not work on my install. I have the background track enabled only on the homepage. But the music does not stop when clicking the button. What am I missing?

    http://globalmanagementalliance.com

    https://wordpress.org/plugins/soundy-background-music/

  2. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    I don't see Soundy's Play/Pause button on http://globalmanagementalliance.com/.

    The only Play/Pause button I can see is the one of the slideshow, which does not belong to the Soundy plugin.

    Also, in the source code of this page, I don't see Soundy's code.

    Are you sure that you have enabled Soundy Background Music on this page ?

  3. mhknuckles
    Member
    Posted 1 year ago #

    Thanks for response. I deactivated the pluggin when I couldn't locate any solutions to the button not working. Will try again today and update if any change.

  4. alipaca
    Member
    Posted 1 year ago #

    I just installed Soundy, but am having issues with the play/pause button. It doesn't pause the song, but actually starts another version when play is hit again. Any advice? Thank you so much!

    Here's one of the pages I'm planning to use it on...
    http://aroseweddingphotographer.com/portfolio/laughter/

  5. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    In what browser on what platform does the problem occur ?

    There are issues with Soundy on MS Windows XP on some brothers. As Microsoft is stopping support of this operating system, I don't want to spend to much time on these issues.

    Tell me if the problem also happens on other platforms.

  6. alipaca
    Member
    Posted 1 year ago #

    I'm using google chrome as my browser, and have windows 7 for my OS.

  7. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    Does the Play/Pause button on the following page work in your browser ?

    http://www.magalibourquin.com/

    If yes, your Play/Pause problem might be a server side issue.
    If no, the problem is definitely a local browser/OS issue.

  8. silviafavilli
    Member
    Posted 1 year ago #

    Hi! First of all, great plugin! Love it! I have the same issue: enabled the play/pause buttons but sometimes they work, most times they don't. Should this be a server side issue, like you suggest in the previous post, any idea what this can be due to and how to solve it?
    Thank you :)

  9. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    If you access http://www.magalibourquin.com/ or http://www.hanstylewedding.com/ with your browser, do the play/pause button of these sites work for you ?

    If yes, your problem might be a server side issue with your site. If not, it might be a client / browser issue.

    Thanks to tell me.

    Also, is it possible to see your page which causes problems ?

  10. silviafavilli
    Member
    Posted 1 year ago #

    The buttons of those 2 sites work correctly (I'm able to play/stop music). This is my site (still under construction)
    http://www.idoyourphotography.com/
    In this moment, for exemple, on the home page the button works, on "about us" page, it doesn't
    Thank you

  11. alipaca
    Member
    Posted 1 year ago #

    I figured out a work-around... In you default settings, make sure you have the background and auto-play deselected, but when you set the pages up individually to play, set the auto play to no and enable background to yes. This is how it looks on my end (but you do have to hit play for the music to start)... http://aroseweddingphotographer.com/portfolio/love/

  12. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    On the site http://www.idoyourphotography.com/ it is a jQuery library problem.

    silviafavilli, your theme uses a jQuery library which is to old: http://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js

    Soundy requires the 1.10.2 jQuery library, which is available in WP 3.6, 3.7, 3.8 and 3.9.

    I've taken the source of the ABOUT US page of your site, replaced the line
    <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js?ver=3.9'></script>
    with
    <script type='text/javascript' src='http://webartisan.ch/wp-includes/js/jquery/jquery.js?ver=1.10.2></script>
    and put the code in http://webartisan.ch/test.htm.
    If you access http://webartisan.ch/test.htm, you can see that the Play/Pause button works as expected.
    So please, check with your theme author why he doesn't use jQuery 1.10.2
    Thanks

    Hope this helps.

  13. silviafavilli
    Member
    Posted 1 year ago #

    This helps a lot. Thank you so much :)

  14. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    alipaca, thanks for the work-around.
    However, autoplay should work.
    It looks like it is also a jQuery library issue.
    From the source code of your page, I could not figure out what jQuery library is used.
    Please insure with your theme author that it is jQuery 1.10.2.
    Thanks

  15. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    The source code of http://globalmanagementalliance.com also contains this include:
    <script type='text/javascript' src='http://globalmanagementalliance.com/wp-content/themes/CherryFramework/js/jquery-1.7.2.min.js?ver=1.7.2'>

    Again, jQuery 1.7.2 is too old for Soundy.

    Soundy requires jQuery 1.10.2 which is part of the WordPress 3.6, .7, .8 and .9 core.

    These themes should just use WordPress's jQuery Library instead of loading their old own version.

  16. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    To wrap up about this Play/Pause button issue, Soundy just needs an up-to-date jQuery library, which is right now jQuery Version 1.10.2.

    Using WordPress Default jQuery library is actually what Soundy does with the following statements in soundy.php:

    wp_register_script( 'soundy-front-end', $this->plugin_url . '/js/front-end.js', array( 'jquery' ) );
    wp_enqueue_script( 'soundy-front-end' );

    array( ‘jquery’) is an argument to wp_register_script saying that front-end.js depends on WordPress default jQuery library.

    And this is what your theme also should do instead of loading its own old jQuery version.

  17. Bertrand du Couedic
    Member
    Plugin Author

    Posted 1 year ago #

    In Soundy Version 2.0 and later, you can now set the variable $use_own_jquery_lib_on_front_end to true in the main Soundy PHP file: soundy.php.

    To make this modification:

    1. Go to the plugins page.
    2. Click on the Edit link of the Soundy plugin.
    3. Look for the variable and set it to true.

    This should fix the "Play/Pause Button Not Responding" issue.

  18. zack06007
    Member
    Posted 10 months ago #

    i have a same problem :(

  19. Bertrand du Couedic
    Member
    Plugin Author

    Posted 10 months ago #

    With the new version, Soundy Background Music 2.4, there isn't any more the $use_own_jquery_lib_on_front_end variable, as having a plugin loading its own jQuery library is against the WordPress plugin development rules.

    Thus, Soundy just uses the default WP jQuery library and this is what all themes and plugins should do.

    One plugin, which doesn't follow this rule is enough to break other plugins.

    Please ensure that your theme and all other plugins use the default WP jQuery library and not their own one.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Soundy Background Music
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.