WordPress.org

Forums

[resolved] [closed] Play/Pause Button is Missing on Natively Embedded audio (19 posts)

  1. EricMesa
    Member
    Posted 2 years ago #

    When I upload and embed mp3 files the player appears and if I click where the play button should be, it plays. However there is no button there. Everything from the GUI appears to be there - timestamp, length of audio, volume slider, position slider.

    Bug? Something I need to double-check from the updgrade?

  2. Hi Eric, could you please provide a link to a page where you are having this issue? It worked fine on my dev install here.

  3. EricMesa
    Member
    Posted 2 years ago #

  4. Pioneer Web Design
    Member
    Posted 2 years ago #

    I used Chrome to delete the node for the top audio player and then the video played - looks like WP3.6 Media embeds with multiple players on a page seem to be troublesome...

  5. Perhaps your server isn't playing nice with the SVG mime type. Could you try adding the following to your .htaccess file?

    AddType image/svg+xml svg svgz
    AddEncoding gzip svgz

    Something is not working right on your site but it's not a core bug. Let me know once you've added that -- it may work or it may not :)

    Edit: Also, if you could disable all plugins while we troubleshoot that'd be helpful :)

  6. EricMesa
    Member
    Posted 2 years ago #

    Did that and it was fixed. Yay! (needed to reload cache)

  7. I see it now! Clear your cache :)

  8. EricMesa
    Member
    Posted 2 years ago #

    haha, yes. OK, I will mark it as resolved.

  9. Just to confirm, did the .htaccess addition resolve this problem? It's good to know for future folks who visit this thread.

  10. EricMesa
    Member
    Posted 2 years ago #

    Yes, I did not change anything but the .htaccess.

  11. Pioneer Web Design
    Member
    Posted 2 years ago #

    After reviewing a bit more, it looks like some style being added at some point is causing the issue with the audio player button...could not nail it down, but I can see the button load then go away...if you have not customized twentythirteen, look at plugins....deactivate them all and test.

  12. jodzeee
    Member
    Posted 2 years ago #

    I had the same problem. I tried deactivating all plugins and still had the issue, but changing the .htaccess worked.

  13. jbeckl
    Member
    Posted 1 year ago #

    As a newbie, can you give me quick instructions to add this to my .htaccess without messing up my theme?

  14. jodzeee
    Member
    Posted 1 year ago #

    I use the Yoast SEO plugin that allows editing of the .htaccess file, but you should also be able to access it via FTP.

  15. aaronsalt
    Member
    Posted 1 year ago #

    I've changed the .htaccess file and I'm still having the issue.

    I'm using 3.8. Anyone have tips for showing the controls here? It loads and then disappears.

    EDIT: Forgot to reload cache. Working like a charm after .htaccess edit!

  16. chood73
    Member
    Posted 1 year ago #

    THANK YOU GUYS!!! This fixed me right up!

  17. diamondjim
    Member
    Posted 1 year ago #

    I am using IIS7 and .htaccess is not supported, however if you are a server admin you can modify IIS to add the IE9 mime types needed. I just tried this and by god, it worked! I can now see the play button.

    Just make sure your server does not already have these listed, as dupes are not good. I am using Windows 2008 server.

    Here is the KB article on how to do this
    http://www.iis.net/learn/manage/managing-your-configuration-settings/adding-ie-9-mime-types-to-iis

    http://www.barnjazz.com

  18. Jerry Gartner
    Member
    Posted 1 year ago #

    Thanks @Patrick Nommensen - the htaccess addition fixed it for me too on a linux server.

  19. jobst
    Member
    Posted 1 year ago #

    Thanks Patrick Nommensen, this fixed my problem, included it in the httpd.conf of all of my servers.

Topic Closed

This topic has been closed to new replies.

About this Topic