Support » Plugins and Hacks » [Resolved] Playlist Link text shows in excerpt

[Resolved] Playlist Link text shows in excerpt

  • In the theme I am using, the text for the Add as favourite appears at the beginning of excerpts. It is not a link, just the text. This only appears if logged in.

    What needs to be changed in the plugin to prevent this? I’m working with a cloned copy of the plugin because of other changes I have already made, so I cannot simply upgrade if you make changes in the plugin. I am not an expert at PHP or jquery, so cannot see where to make the change.

    I like this plugin!


Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Pasquale Ambrosio



    Sorry but , I didn’t understand what you want to do 🙂

    If you don’t want to show “Add as favoutite” can disable this option by configuration panel into section “Show in…”

    If this isn’t that you want, please make it clear what would you like.

    Sorry I did not explain properly. Let me try again:
    Setting is “Show in Posts”. The link text “Add as favorite” is appearing at the beginning of the excerpt when post excerpt is displayed in a widget. This only happens when user is logged in. I do not want the link text to appear at the beginning of excerpts, only when showing single post.

    I hope this explains better

    Plugin Author Pasquale Ambrosio


    What version of plugin are you used?

    if you want see the “add favourite” only inside the post, you have check from configuration panel, only show in post


    check inside core.php the function shortcode_posts_playlist this code:

    if(is_single() && $wp_posts_playlist['show_in_posts']=='show')
       return $_link;
    if(is_page() && $wp_posts_playlist['show_in_pages']=='show')
       return $_link;
    if(is_home() && $wp_posts_playlist['show_in_loop']=='show' )
      return $_link;

    in previus version, there was a bug about the saving of this flag.

    I suppose you use a old version: probabily it’s for this reason I didn’t understand you…

    Now using 1.3.3 and the “add to favorite” text is still showing in excerpt in sidebar when user logged in.

    Plugin Author Pasquale Ambrosio


    The plugin work in this way: the link to add or delete favorite, are showed only when the user is logged.

    Yes, I understand that, but in excerpts in the sidebar, the hyperlink is stripped out so it only appears as text appended to the front. For example, it shows in excerpt:

    Add as favoriteThis is is a little trick I learned…

    It appears OK on the post page in the main content area. Is there a way to stop it from appearing in excerpts but still appear in main content area?

    Plugin Author Pasquale Ambrosio


    send me a print screen…

    Plugin Author Pasquale Ambrosio


    I tryed to edit theme base of wp, to reproduce that you show me, changing the call the_content() with the_expert(), and I have not the same issue.

    To help you, if you can, send me part of code.

    Thanks, that gave me the information I needed to fix the problem. I changed the widget from get_the_excerpt() to get_the_content() – and trimmed it – and it now functions properly.

    By the way, I also added a hack that includes a “add to favorites” link when not logged This links to the login page. I find it encourages people to subscribe.

    Thanks again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Playlist Link text shows in excerpt’ is closed to new replies.