Support » Plugin: WordPress Email Template Designer - WP HTML Mail » Plain text emails not being rendered correctly

  • Resolved uisneach

    (@uisneach)


    I am using version 3.0.4 of your plugin and WordPress 5.6
    It works great when html emails are being sent from the system.
    However, for default emails being sent from WordPress for “Email Changed” or “Password changed”, the text of the email is all in one line with no line breaks.
    It feels like the content of the email should be passed through wpautop()

    I have experimented with turning on/off the “Allow html code in plain text” setting but to no avail. Is there another setting I should be changing?

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support juliangk

    (@juliangk)

    Hello @uisneach,

    can you please upload a screenshot to a picture sharing site and post the link here?

    I can not recreate the problem on my test system, with a fresh installation of all up to date versions of WP and the plugin.

    Thank you and best regards
    Julian

    Thread Starter uisneach

    (@uisneach)

    Hi Julian,
    Here is a screenshot of the email, with all the personal details blanked out.
    2021-01-24_02-59-51

    I noticed that if I made a call to wpautop($email[‘message’]) towards the end of the style_mail() function in class-haet-mail.php it would render the email correctly but hacking the plugin isn’t a good idea. It sounds like maybe the content type isn’t being interpreted correctly for these system emails?

    Plugin Support juliangk

    (@juliangk)

    Hello @uisneach,

    as I could not recreate the problem, I would kindly ask you, to e-mail us to support@codemiq.com, referring to this thread, so we can continue support privately.

    Thank you and best regards.

    Julian

    Plugin Support juliangk

    (@juliangk)

    Hi @uisneach,

    as stated in the e-mail, the use of the ‘wp_mail_content_type’ filter in your child theme was responsible for the issue.

    Therefore, I will mark this thread as resolved.

    Best regards
    Julian

    Thread Starter uisneach

    (@uisneach)

    Thanks Julian – that solved it.
    Awesome plugin and awesome support!!

    Plugin Support juliangk

    (@juliangk)

    @uisneach

    Thank you very much for the feedback!
    If you have any further issues, let us know.

    Best regards
    Julian

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.