Support » Plugin: Advanced Ads – Ad Manager & AdSense » Placements with Toolset Layouts

  • Resolved dieter93

    (@dieter93)


    HI,
    i use toolset layouts on custom post types and the complete placements is not working.
    I can use add-shortcuts with toolset layouts witch is working but a placement like Content is not working. All the other placements also not work in toolset layouts.
    Any idears to get placements work together with toolset layouts?

    Greetings

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi dieter93,

    thanks for reaching out.

    I have no experience with Toolset. From what I understand, it is a premium software only, right?

    Could you reproduce the issue if I set you up with a test site on our end?

    Thanks,
    Thomas

    Hi Thomas,

    yes Toolset is a premium plugin suite an Layouts is one plugin of them. Layouts is working like a pagebuilder with rows and cells and you are in a position to load fields and views and standard WordPress stuff like Post-Content, Feature-Image and so on.
    If you do that, then Toolset will not load the single.php file for this content anymore.
    It looks like, that placements in advanced-ads is not able to fit in this layout structure generated from Toolset Layouts.

    When i create a normal custom post type wich is only use the single.php without Layouts, all the placements works fine.

    And yes, i have this problems on other sites as well, also on test sites.

    Looks like we just can’t?

    Greetings,
    Dieter

    Plugin Author Thomas M

    (@webzunft)

    Hi Dieter,

    thanks for your knowledgable feedback. There might be a way in if the problem is caused by the new layout not using the the_content filter. Do you know if they do?

    If the filter is missing then maybe you can add it or use another one. See https://wpadvancedads.com/manual/post-ad-injection-placement/#Ad_injection_without_the_content.

    Thanks,
    Thomas

    dieter93

    (@dieter93)

    Hi Thomas,

    Toolset Layout is using the_content filter. There are options too for enable/disable third-party-plugins-filter witch hooked in the_content filter.

    I will contact Tooset Support. Maybe they can give me some more details or we will find a solution.

    When I have found out more, I will let you know.

    Thanks for your support 🙂

    Greetings
    Dieter

    Plugin Author Thomas M

    (@webzunft)

    Hi Dieter,

    thanks for your feedback. I am indeed curious about their reply and happy to help finding a solution.

    Thomas

    Plugin Author Thomas M

    (@webzunft)

    Hi Dieter,

    I hope you are well. Did you find a solution by now or is there anything I could help with?

    Best regards,
    Thomas

    Hi Thomas,

    Thanks, I’m fine 🙂
    Toolset support was able to reproduce the problem and shared it with the development team.
    They’ll get back to me.
    Thank you for your offer to help. When Toolset Team have contacted me, I will inform you here about the progress.

    Thanks and have a nice weekend
    Dieter

    Beda

    (@bedas)

    Hello Thomas, this is Beda from Toolset Support.

    I found that Dieter is facing this issue https://wpadvancedads.com/manual/ad-health/#the_content_filter_found_multiple_times.
    Yes, Toolset Layouts uses the content filter at more than one place potentially.

    It seems, the code in file /advanced-ads/public/class-advanced-ads.php is successfully stopping all content filters to display the injected data in this case?
    See public function inject_content( $content = '' ) from line 454 ca. onwards.

    If I understand it right, it seems “expected” that in the case of several calls to the content filter the plugin (understandably) tries to catch that and avoid injecting the data at this point?

    If you need a copy of Toolset or a (free) Developer license to test with, please feel free to contact me at beda.s + @ + onthegosystems.com
    I can also assist with further information or if required, I can forward suggested changes in the code to our developers, if it is required.

    Thanks!

    • This reply was modified 10 months ago by Beda.
    Plugin Author Thomas M

    (@webzunft)

    Thanks @bedas, I will reach out directly since I might take you up on the offer to work on the code together.

    Best regards,
    Thomas

    Hi Thomas,

    raising the “Priority of content injection filter” option to “1000” fix the problem.
    Thanks for you help to check this out!

    Big thanks 🙂
    Dieter

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Placements with Toolset Layouts’ is closed to new replies.