Support » Plugin: Pixel Caffeine » Pixel not firing on Purchase sometimes

  • About 50% of the time when I get a sale the purchase pixel will not fire. My hunch is that it’s PayPal and they are not returning to the site after? How can I fix this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Looking for that too.
    Addtopaymentinfo is better in this situation because fires every time after positive checkout. But how to change/ search place where is code for that? That will be somehow easy solution.

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    sorry for the issue, unfortunately at this moment the only way to track the event is on Thank You page, but we are working to register the payment complete event and send the purchase event afterward on a next page loading, in order to avoid to miss the event because the user didn’t visit the thank you page.

    I hope to release this fix soon in one of the next release.

    warczok111

    (@warczok111)

    Is it possible to just put the purchase code exactly in same area where is addtopayment code in any easy way?

    soulipsyz

    (@soulipsyz)

    I’ve done an automatic redirect back to the Thank You page using PayPal, so far this seems to be working. Let me know when you have the new update though. Thanks

    Plugin Author Antonino Scarfì

    (@antoscarface)

    @warczok111: nope, it’s not possible, sorry. Furthermore, at that moment you cannot know if the purchase will be completed or not.

    @soulipsyz: glad to hear you found a workaround for that. I’ll notice about the feature in the changelog of next releases, so keep an eye on that 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Pixel not firing on Purchase sometimes’ is closed to new replies.