Support » Plugin: Shariff Wrapper » Pinterest “The image could not be loaded”

  • Hallo,

    Ich bekommen beim Klick auf den Pinterest shariff Button die Meldung “The Image could not be loaded”. Wenn ich jedoch auf “The Image” klicke oder direkt einen Rechtsklick auf den Pinterest Button mache und den Link in einem neuen Tab öffne, kann ich das Bild wie gewohnt pinnen. Woran kann das liegen?

    Liebe Grüße

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jan-Peter

    (@starguide)

    Hallo jassi678,

    da scheint es einen Konflikt mit einem anderen Plugin zu geben. So wie es scheint eines, dass Links zu/mit Bildern in einer Lightbox öffnet. Normalerweise sollte ja ein neuer Tab aufgehen, so wie bei Facebook daneben.

    Du könntest einmal versuchen, ob es besser klappt, wenn du die Option unter “Design” anmachst “Links in einem Popup öffnen (erfordert JavaScript).”.

    Viele Grüße
    JP

    Ich habe ein ähnliches Problem mit Pinterest auf der Seite https://www.digitalzimmer.de/.

    Beim Teilen von Pinterest öffnet sich zwar ein neues Fenster, auch die Headline der Seite ist schon voreingetragen. Es wird aber kein Bild geladen. Am Server liegt es nicht, denn über ihren WordPress-Pfad sind die Bilder ganz normal erreichbar.

    Eine Idee, woran es liegen könnte?
    Viele Grüße

    Plugin Author Jan-Peter

    (@starguide)

    Hallo fgruen,

    du hast auf deiner Seite einen Hotlink-Schutz aktiv. Dieser verhindert, dass Bilder von deiner Seite auf anderen Seiten eingebunden werden können. Das blockiert leider auch das Abrufen der Bilder durch Pinterest.

    Du müsstest diesen Schutz wieder abschalten / entfernen damit es funktionieren kann.

    Viele Grüße
    Jan-Peter

    P.S.: Im übrigen ist es ein absolutes Unding den Rechtklick per JavaScript auf seiner Seite zu blockieren. Das schützt genau vor gar nichts und behindert stattdessen den Zugang für Menschen mit Einschränkungen. Das solltest du unbedingt ebenfalls entfernen.

    Hallo Jan-Peter,

    seit zwei oder drei Tagen habe ich das Problem plötzlich auch, dass die Pinterest-Bilder beim Pinnen nicht mehr “angeboten” werden. Es muss nicht unbedingt am Shariff Wrapper liegen, da die anderen Bilder (Beitragsbild, Logo usw.) auch nur sporadisch vorgeschlagen werden. Aber da mehrere dieses Problem haben, lässt sich vielleicht ein Zusammenhang finden?

    Ich finde es grandios, das man mit SW ein Pinterest-Bild hinterlegen kann und würde das gerne wieder nutzen.

    Beispiel-Link: https://www.lebens-essenz.com/der-itovi-scanner-ist-bis-ende-august-ermaessigt/

    Gruß, Saskia

    • This reply was modified 9 months, 1 week ago by lebensessenz. Reason: Link vergessen
    Plugin Author Jan-Peter

    (@starguide)

    Hallo Saskia,

    bitte am besten immer ein eigenen Thread eröffnen und sich nicht an alte dran hängen, sonst wird das sehr unübersichtlich. Bei dir scheint es sich nicht um ein Hotlinking-Problem zu handeln.

    Ich habe es gerade einmal getestet und Pinterest schlägt mir ganz normal das jeweilige Bild zum Beitrag vor. Hast du eventuell bei dir einen Adblocker im Browser aktiv? Wie schaut es aus, wenn du es mal mit einem anderen Browser testest?

    Viele Grüße
    Jan-Peter

    Hallo Jan-Peter,

    okay, nächstes Mal eröffne ich einen eigenen Thread.

    Ja, Pinterest schlägt Bilder vor, und zwar das Beitragsbild, das bei YOAST SEO hinterlegte Logo und “Rückfallbild”, aber nicht das extra für Pinterest hinterlegte Bild. Ich habe es jetzt in drei Browsern (Chrome, FF und MS Edge) ausprobiert und auch jeweils den AdBlocker, sofern vorhanden, deaktiviert. Es bleibt aber leider so…

    Zum Vergleich, dies ist das Bild, das ich für Pinterest im Plugin hinterlegt habe: https://www.lebens-essenz.com/wp-content/uploads/2019/08/itovi-angebot-pinterest.jpg.

    Es wäre toll, wenn Du mir helfen kannst bzw. sagen kannst, was ich noch ausprobieren kann.

    Danke und viele Grüße

    Saskia

    Plugin Author Jan-Peter

    (@starguide)

    Hallo Saskia,

    bei mir schlägt er auch genau das Bild vor und zwar nur das.

    Siehe Screenshot:
    https://imgur.com/a/rZgtByN

    Hast du vielleicht einmal einen anderen Pitnerest-Account zum Testen? Oder einen Freund/Bekannte, die mal testen könnte? Wie gesagt, hier verhält es sich genauso wie gedacht.

    Viele Grüße
    Jan-Peter

    Hallo Jan-Peter,
    das ist ja wirklich skurril! Ich habe mit drei accounts, auf zwei Rechnern, eingeloggt auf meiner Webseite und nicht eingeloggt, im privaten und im normalen Modus, mit Pinterest-Browser-Button und mit Pin erstellen/aus Webseite hochladen, mit drei verschiedenen Browsern, mit Cache löschen usw. ausprobiert. Immer waren nur die drei Bilder von der Seite zu sehen…

    https://imgur.com/luUy7xd

    Ich werde morgen nochmal eine Freundin fragen… oder mehrere.

    Vielen Dank für Deine Mühe!

    Viele Grüße

    Saskia

    • This reply was modified 9 months, 1 week ago by lebensessenz.
    lebensessenz

    (@lebensessenz)

    Hallo @starguide Jan-Peter,

    ich habe weiter ausprobiert. Ich habe es auf einem Browser ohne Ad-Blocker, den ich noch nie verwendet habe, versucht. Ich habe es mit einem neuen Blogartikel versucht. Nichts hilft. Am meisten wundert mich, dass Du den Pin sehen kannst. Ich bin ziemlich ratlos, was ich noch versuchen soll. Diese Funktion des Plugins ist so wahnsinnig hilfreich. Von daher würde ich mich freuen, wenn du noch einen Tipp hast…

    Danke und viele Grüße

    Saskia

    lebensessenz

    (@lebensessenz)

    Lieber Jan-Peter,

    noch ein Nachtrag. Auch andere haben es jetzt ausprobiert. Alle sehen den richtigen Pin. Nur ich nicht. Also kann es nur an meinem Rechner oder an meinem Pinterest-Account liegen. Denn bei mir funktioniert es bei keinem Browser, also liegt es daran nicht.

    Ich weiß, dass das jetzt nicht Dein Problem ist, da es wohl kein Problem des Plugins ist. Falls Dir was einfällt, bin ich also besonders dankbar…

    VG

    Saskia

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Pinterest “The image could not be loaded”’ is closed to new replies.