WordPress.org

Forums

Share Buttons by AddToAny
[resolved] Pinterest service not found (5 posts)

  1. garciamember
    Member
    Posted 11 months ago #

    Hi,
    There is some kind of issue with Pinterest service not being available. I'm using custom icons, they appear right and Facebook or Twitter are working ok, but when I click on Pinterest icon, which has href:
    http://www.addtoany.com/add_to/pinterest?linkurl=xxx&linkname=yyy, where xxx is link to blog and yyy has a name of a post, I see "Service not found" page on addtoany.com.
    Please let me know here, if it is temporary and when it would be fixed (if at all).
    Thanks,
    Garcia

    https://wordpress.org/plugins/add-to-any/

  2. micropat
    Member
    Plugin Author

    Posted 11 months ago #

    Hi Garcia,

    AddToAny loads Pinterest directly on your actual site, so the redirection (and 'service not found') is a sign that your site is not loading AddToAny (and likely other important components) due to another site issue.

    Try the "Something is wrong" general troubleshooting, and if you haven't pinpointed the issue after that, feel free to point us to your site so folks here can take a look.

  3. Pobux
    Member
    Posted 11 months ago #

    Exact same problem, facebook, linkedin and twitter are working properly.

    The link that redirect to pinterest via addtoany seems to be the problem.

    My code :

    <li><a target="_blank" class="a2a_button_facebook fb"></a></li>
    
                      <li><a target="_blank" class="a2a_button_linkedin ln"></a></li>
    
                      <li><a target="_blank" class="a2a_button_pin pin"></a></li>
    
                      <li><a target="_blank" class="a2a_button_twitter twitter"></a></li>

    The url from addtoany
    http://www.addtoany.com/add_to/pin?linkurl=http...

    Compare to
    http://www.addtoany.com/add_to/twitter?linkurl=http...

    Twitter works not pinterest

  4. micropat
    Member
    Plugin Author

    Posted 11 months ago #

    @Pobux you have the same site issue as I mentioned above to Garcia.

    Try the basic troubleshooting steps of temporarily switching to a default theme and temporarily disabling other plugins to find the cause. If you don't find the root issue, start a new topic and point to your site so folks here can help you.

  5. micropat
    Member
    Plugin Author

    Posted 11 months ago #

    @Pobux your specific issue is probably related to a short-lived AddToAny bug yesterday. That issue was quickly fixed, and I posted about it over here too: http://wordpress.org/support/topic/pinterest-button-not-working-6?replies=2#post-5698940 — sorry for any confusion if you were one of the unlucky few!

Reply

You must log in to post.

About this Plugin

  • Share Buttons by AddToAny
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic