• Hello,

    I have tried several social sharing plugins.
    But with every plugin, for Pinterest save share button there is a same error message:
    Sorry! Something went wrong on our end. Please try again.

    Does anybody know why I’m having this issue?

    Thanks for the help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • Pinterest has deprecated anything but the addition of their code to your site. Please see:

    https://developers.pinterest.com/tools/widget-builder/?

    Thread Starter amedic

    (@amedic)

    Thanks for the info @swansonphotos,

    I have implemented widget according to your suggested URL:
    https://developers.pinterest.com/tools/widget-builder/?
    but, unfortunately I have the same error message.

    @amedic,

    Since you are using both Autoptimize (plugin) and Cloudflare (CDN), please make sure to:

    After all/any/each site edit(s):

    1. Clear the cache plugin.
    2. Clear the CDN Cache and force an update with CDN.

    Please review with each how that all works.

    Thread Starter amedic

    (@amedic)

    Hi again @swansonphotos, and thanks for the help.
    I have disabled caching plugin, and clear the CDN cache after the update, but unfortunately it was still the same error:
    Sorry! Something went wrong on our end. Please try again.
    This is really weird, because I remember it worked flawlessly before.

    It’s working fine on sites I admin/host. Try grabbing the widget code again and make sure it’s applied in the correct theme template files and in the proper place.

    Thread Starter amedic

    (@amedic)

    Hi @swansonphotos,

    thank you for the reply.
    On my site it also been working with no problems.
    But recently, after couple months without activity on the site, I wanted to “pin” an URL and I have found out that it is not working.

    I do not know were is the problem.
    I have implemented official Pinterest Save button, I have disabled W3TC, Autoptimize and Cloudflare when I was testing it, but the error was the same.

    I have contacted Pinterest Help, but they are still unable to help me.

    Does anybody have an idea what can be wrong?

    Hello amedic,

    I’m having the same problem with my site. Pages cannot be pinned whether you use the Addtoany button or you enter the url of the page into pinterest directly. Pinterest has told me they know of the issue and are working on it. But it’s been 2 weeks and we haven’t heard back yet. I’ve tried all different pages and none of them can be pinned. Same error message: Sorry! Something went wrong on our end. Please try again.

    My site is https:/www.nextgenmemorials.com

    I tried adding the pinterest recommended code into a widget too and that had the same error.

    Sharon

    I am having similar issues and have checked on absolutely everything possible. I currently use the Social Warfare plugin for Pinterest images and links, but even when that plugin is disabled and I use the chrome pin it button, it doesn’t work. I have had a ticket ongoing and have gotten a response usually around once per week since October 8 with Pinterest. I haven’t heard anything back since October 20 from them, which is frustrating.

    The last thing the Pinterest person sent me was this: “Focusing on your most recent blog post as you mentioned, I see that our crawler is blocked by your site. I checked your robots.txt file and you’re not blocking our crawler there. Is there anything set up on your hosting provider that would block our crawler? Here is our user agent info: https://help.pinterest.com/en/articles/about-pinterest-crawler-0”

    I tried to update by robots.txt file and it did not work. My host tested Pinterest IPs to be sure they weren’t being blocked. I also reached my wordpress theme vendor troubleshoot, my husband who does code debugging, and the plugin vendor as well. No one has an answer accept that they’ve seen it before and Pinterest was able to fix it.

    I’m having similar issues. Some images on my website seem to pin just fine yet others return the same “Sorry? Something went wrong on our end” error.

    At first I thought it was Social Warfare plugin causing the problem, so I switched to different Social Media Sharing plugin. Same problem as some PIN fine and some return the error.

    I am now having this issue. It started a couple months ago then stopped and now it is on-going. My Pinterest save button was working perfectly fine till recently. Now I am getting the same error message “Sorry something went wrong, please try again.” I have tried everything suggested here, has anyone found a solution to this issue? Could this possibly be a WordPress issue? I have read a few people stating this. I have put in a ticket with WordPress but still, no response and that has been almost a week ago.

    Having the same problem. Following.

    This was happening to me with a different plugin. I added a new plugin, and same issue.

    A friend is using the same plugin on her website and it works fine.

    I created a brand new Pinterest account. Same issue. Still working fine on my friend’s site.

    I checked the HTML that calls the Saving of the pin, and it matches my friend’s site’s exactly.

    I’m dumbfounded by this.

    Anyone manage to resolve this yet?

    I wonder if it is related to the fact that my website won’t validate in Rich Pins.

    To all of you who are having the issue: do this and report your results:

    Get the URL to one of your blog posts (in my case “http://www.inacoveney.com/why-should-i-get-an-llc/”) and punch it into the Rich Pins validator here:

    https://developers.pinterest.com/tools/url-debugger/

    Does it validate for you?

    It doesn’t for me. Just curious to see if there’s a pattern here.

    Pinterest cannot support every site that doesn’t validate, so they have not been helpful in providing a solution.

    4/24/2018 – Problem persists. I believe at this point they have no idea what they’re doing.

    Uuuuuggg thank you @trusake. I am still having the issue as well with no update from anyone. If you or anyone else may find the cause please let me know!

    I am curious. You guys that are having this issue, do you have your own website you are trying to pin from, or is it just in general. I just checked and it allows me to repin on Pinterest, so it is just when I am trying to Pin from my blog website. My Host is IPage, but currently looking to switch, possibly Hostgator, and also thinking about buying a whole new Domain and just transferring my website to it. Ipage is not helping me at all with this issue, and of course Pinterest IT techs couldn’t either, just stated that it could be a security certificate issue, but no issues were found by my host.

    • This reply was modified 6 years, 1 month ago by heathergantt.
Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Pinterest save button error: Sorry! Something went wrong on our end. Please try’ is closed to new replies.