WordPress.org

Support

Support » Plugins and Hacks » WPSocialite » [Resolved] Pinterest Not Working Properly

[Resolved] Pinterest Not Working Properly

  • On hovering one post (In archive or homepage), it works as expected, loaded pin button. But if you hover any second post, it’ll not work properly, at least in my case.

    I looked at console of Chrome, I got following error:
    Uncaught TypeError: Cannot call method 'removeChild' of null repated (2 times) wpsocialite.js Line: 7

    I have removed the Pinterest option currently from my site. If you need to investigate, I’ll check the option and will give you link.

    I hope you can resolve it soon.

    -Aditya Pandey

    http://wordpress.org/extend/plugins/wpsocialite/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Tom Morton

    @tm3909

    Odd, I’ll take a look when I’m back at my desk and see why pinterest is acting up.

    Plugin Author Tom Morton

    @tm3909

    Looks like an issue with the Pinterest extension from Socialite itself. Working on a solution.

    +1 I think same.
    By the way, did you able to replicate the issue?

    Thank you.

    I’m having the same issue. Would love to see if this can get fixed!

    Plugin Author Tom Morton

    @tm3909

    Hey Mike,

    Yea this is a known issue. Fix coming this weekend (all releases normally happen on weekends).

    Will be sure to reach out once the fix is up.

    Thank you Tom. Great plugin!

    Plugin Author Tom Morton

    @tm3909

    Hello All,

    I just pushed up the latest version of WPSocialite (1.6) which fixes the pinterest issue. Please upgrade and review.

    Going to close this for now, but if you have any issues related to pinterest be sure to let me know ASAP.

    Pinterest stil doesn’t work for me. I click the button and it drops the “pin it” popup, but I don’t see the pin in my pinterest profile anyways 🙁

    Plugin Author Tom Morton

    @tm3909

    So you are saying its not actually pinning to your site? I’d be interested in seeing what the others are experiencing.

    Can you like me to your site so I can test-pin?

    thanks for the quick response Tom.
    I’ve set-up a test site to reproduce the issue at http://test.graystyle.hu/ and no pin.

    my other sites works the same way 🙁

    Pinning seems to work for me on a site that I am using the plugin for. I did notice that your post did not include an image – don’t you need an image to enable pinning? Pinterest is image based no? (I’m not very familiar with pinterest)

    the site has a sample image and if I use the pinterest button in my bookmark then it works fine

    Quick update: the problem was with the post that didn’t have featured image selected and the other sites we use cdn (also no featured images).

    Slight changes solved the issue – I’ve added a small function to get the first image src from the post content.

    Thanks for the great plugin!

    Really liking the plugin, but Pinterest button is not displaying for me at all. Buttons are at bottom of post.

    http://www.tourabsurd.com/postcard-chiang-mai-elephant-nature-park/

    Thanks for all your work on this. 🙂

    Plugin Author Tom Morton

    @tm3909

    TourAbsurd,

    I just checked out your site and it looks like classes that are not supposed to have been added to wpsocialite have been added to the pinterest call.

    Have you modified the plugin at all? Do you have any other social plugins that are active currently? If you do, I would try disabling them and see if pinterest shows up.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Pinterest Not Working Properly’ is closed to new replies.
Skip to toolbar