Support » Plugin: Share Buttons by AddThis » Pinterest and LinkedIn buttons do not appear

  • I selected the default set of icons and selected to have them display below my content. This worked well, but the Pinterest and LinkedIn buttons did not show.

    I went into the Advanced tab to customize my links and used the following:


    Saved my changes, nothing changed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Change pinterestpinit to just “pinterest” and also change google+1 to “google_plusone”. A full list of service codes can be found here:

    Also, you may not see those options in your browser because we have prioritized other social networks for you based on your sharing preferences. So the best way to test this is to either clear your browser cache or use something like Chrome’s incognito window to see what your blog would look like to a new visitor. You can read about sharing preferences here:

    I hope this helps. Let me know if you still have questions.

    Thanks Sol.

    Did the list of service codes change since yesterday? That’s the same list I looked at yesterday, but now they’re updated with the codes you suggested. Or is there an old list floating around somewhere?

    The sharing preferences makes sense, but I’m not sure that it’s being applied consistently. Is there any way to disable this and just show the same buttons across the board?

    On one of my browsers, it shows facebook, twitter and google plus. There’s a strange gap between twitter and google plus. In Chrome, there’s the same gap, but it also exists between google plus and the share button. Is there anything that I can do to fix the design/layout issues?

    I don’t think the list has changed recently, so I’m not sure where you could have gotten those other values.

    As far as disabling share preferences and fixing the layout issues, I would need to see what you have setup and I might be able to propose some CSS tweaks, so if you have the code live on your blog, give me a link and I’ll take a look.

    I know this is a non-issue, but I literally looked at the list yesterday. It might have been a cached version of the page or something, but that’s really strange.

    I’m working locally right now, but thanks anyway! I’m going to leave this thread open in case I discover a related issue.

    Yeah, I’m not too sure why you saw a different version. I don’t know if it’s a caching issue because those service codes aren’t something we update once we release a new service.

    If you’re still having issues positioning the buttons, you should be able to target the specific button by inspecting the element and adding/removing padding as necessary. And to disable the share preferences and hardcode specific services, you will need to use the custom button option are specify the services like this:

    <a class="addthis_button_facebook" style="cursor:pointer"></a>
    <a class="addthis_button_twitter" style="cursor:pointer"></a>
    <a class="addthis_button_email" style="cursor:pointer"></a>

    I hope this makes sense. If you still need help, just let me know.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Pinterest and LinkedIn buttons do not appear’ is closed to new replies.