Support » Plugin: Autoptimize » Pingdom Summary / JS and CSS still not combined

  • Hi there and thanks for the nice plugin. I tested my page on pingdom and saw, that it has very poor grades (F) on both ‘Combine External JavaScript’ and ‘Combine external CSS’. I researhced and people seem to solve this issue using Autoptimize. I downloaded it and configured it, but nothing changed on Pingdom – why?

    PS: I’m parallely using also WP Fastest Cache and WP Optimize.

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, at this moment Autoptimize either isn’t activated (or not configured to optimize HTML, CSS and/ or JS on the settings-page) or it is active & configured but doesn’t work (which would probably be because of a theme or plugin conflict, in which case you would have to disable/re-enable plugins until you find the culprit).

    enjoy your Saturday-evening! 🙂

    frank

    Oh, thanks for the quick response on a Saturday evening! How do I activate Autoptimize? I just saw the options, but no ‘Activate’ button or so?
    And if I disable all the plug insurance, will that nothe ruin my page?
    Thank You once again and
    I hope You enjoy your weekend too!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, if you saw the options the plugin is active. which options did you activate?

    All the optimizations (HTML, JAVA, CSS) + Inline JS & Inline CSS.
    The plugin has a green cicirle next to it in the WP dashboard, but on hover it says 0% / 0,00 kb.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, in that case this applies;

    it is active & configured but doesn’t work (which would probably be because of a theme or plugin conflict, in which case you would have to disable/re-enable plugins until you find the culprit).

    can you try that?

    Thanks again! I tried that and it seemed that Speed Cache and Autoptimize conflicted somehow. I now work with WP Super Cache and the poor ratings on pingdom are no more.
    My site isn’t really fast (score B 85, load time 5.21), but dosen’t really have something to do with Autoptimize.

    Thanks and have a nice Sunday!

    Strange thing i s however, that the Autoptimize Icon atop the WP Dashboard, when clicked on, still shoews ‘0% 7 Size: 0.00b / Files: 0’…

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    had a quick look at your site and there still is no sight of autoptimize in your HTML source I’m afraid, so you’ll have to continue the deactivation-dance (also consider theme) ..

    frank

    Hi Frank, thank You once again for investing time in my issue. I tried the plug in solution and didn’the find a conflict.
    Deactivating a theme is something I’might pretty ‘afraid’ of, as I don’t know how this will reflect on my homepage and I have some big fear of it looking like sh!t, after reactivating the theme. Also, if the theme is the conflict, it wouldn’t really help me, as it’s a paid one I worked a lot on it to have it adapted to my needs. So, changing themeso isn’t really an option for me…
    But everyone’s so happy about Autoptimize and my page really needs it, I guess. Damn.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, if you know it’s the theme, you can contact the author (esp. as it’s a paid one)? maybe test on a non-production site?

    Hey, I contacted the author. It’s not the theme. He says it doesn’t have any known problems with caching and optimization plugins, especially the common ones.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    The only thing I can advice is for you to set up a copy of your site somewhere and disable all plugins except AO + switch to a stock wordpress theme @helidoor and then one by one activate the plugins/ theme you use on your production site to find out which one is breaking things?

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.