Support » Fixing WordPress » Pingbacks to my own blog

  • When I link to a post from another post in my blog, WordPress is sending a pingback to that first post. Is there some way to tell WordPress not to ping posts on my own blog?

    I’m running Spam Karma 2 which of course overrides some of WordPress’s default options for comments.

    Should I just use Spam Karma to blacklist my own IP? The blog is on a server that no one will ever forseeable be running a web browser off of to make a comment.

Viewing 5 replies - 1 through 5 (of 5 total)
  • It’s probably not a good idea to blacklist your server’s IP. You can disable trackbacks from within your post, so that only URLs you enter in the trackback field are pinged. In other words, WP won’t automatically do it any more — this should also speed up writing posts!

    The simple solution to avoid self-pinging: use relative path when linking to your own posts.
    E.g. instead of <a href="<br />
    just use
    <a href="/?p=123...

    Thanks for the info guys. But, I definitely want to auto-ping all the links I have in the post. I link to several other blogs. Entering them all manually sounds like more of a pain than deleting all the self-referencing ping backs on my blog manually.

    I always use relative paths when linking to my own blog. The pingbacks still go through.

    Moderator Michael Adams (mdawaffe)



    Try this plugin: No Self Pings

    Here’s another option:


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Pingbacks to my own blog’ is closed to new replies.