Ready to get started?Download WordPress


[resolved] [closed] Pinboard theme right sidebar issue (16 posts)

  1. SLeece
    Posted 2 years ago #

    I've installed the Pinboard theme in one of my subdomains (test2.nestcreative.ca) and i've selected the right sidebar layout. The theme doesn't seem to allow a single column sidebar (???). I have no need for more than one column, and would really like to change this. I've looked at the code and I can't figure out how to do this (obviously I'm missing something).
    Anyone have any ideas? Thanks in advance! :D

  2. Handoko
    Posted 2 years ago #


    I had same issue too. But by some testings I found that I may get what you want (also me want) by doing this:

    - Remove all widgets in the "Sidebar Left" and "Sidebar Right" area.
    - But put the widgets in the "Sidebar Top".

    It works for me, hope it works for you too.

  3. SLeece
    Posted 2 years ago #

    Thanks for the suggestion, but unfortunately that didn't work for me. :(

  4. Handoko
    Posted 2 years ago #


    Are you sure you have moved all the widgets to "Sidebar Top"?. I've just visited the subdomain site you provided, using browser web developer tool, I can see your "Tag cloud" and "Easy Ads" widgets are still in the "Sidebar Right".

  5. SLeece
    Posted 2 years ago #

    Yeah, I moved those widgets back to sidebar right after I noticed that moving them into sidebar top wasn't working out for me. I'll move the widgets back to sidebar top if you'd like to check it out again. Maybe you'll notice something that I'm not seeing. I really appreciate the help. :)

  6. Handoko
    Posted 2 years ago #

    Yes, this time I can see you did it correctly.

    What I found is not the theme that cause your "Easy Ads" not taking full width, but the "Easy Ads" itself. You may test it by putting a "Calendar" widget into the "Sidebar Top".

    So, how to make the "Easy Ads" widget to take the full width? Here you may try:
    1. Goto the menu: "Appearance" > "Theme Options".
    2. Goto "Layout" Tab.
    2. Put your CSS code in the "Enter your custom CSS" box.

    I'm not a CSS expert, but I think this code may work:

    #sidebar-top.widget-area .easy-ads-widget [style] {width: 100% !important;}

    Make sure you type the code exactly, pay attention with the dot signs, punctuation marks and spaces.

    Good luck!

  7. SLeece
    Posted 2 years ago #

    Thanks! That works perfectly! But now if I try to set the content area (is that the correct terminology? lol!) to 70%, making my sidebar only 30% all of my widgets get pushed to the bottom of the page below the comments area. I've tried checking padding but I can't find the problem.

    Any idea about this one? Sorry to be a pain. This one is really puzzling. :(

  8. Handoko
    Posted 2 years ago #

    You should not set the proportion of content vs widget directly. Because the theme author already done it. Alternatively, you can configure it at "Theme Options" > "Layout" Tab > "Content Columns".

    This theme is awesome, unfortunately lack of documentation. My tests show if the content columns = 4, it means the content width is 75% and widget is 25%. If content columns = 3, it means the content width is 66.6% and widget is 33.3%.

    You mentioned your widgets get pushed the the bottom, I guess you should try to set the content columns value.

  9. SLeece
    Posted 2 years ago #

    Perfect!! Thank you, thank you, thank you!! I had misunderstood what "content columns" meant, but now I get it. I can now mark this topic resolved. :D

  10. jlevant
    Posted 1 year ago #


    Perhaps you could help me as well. I just installed pinboard in a test folder (test.ruxtondesigns.com) and am at a loss in several areas. 1) How can I make the footer text go all the way across the page? - or how can I add a widget to the right side of the footer? 2) how can I get the social media links in the header to open in a separate page? 3) Can I make the header image into a slider? 4) Any idea why the image I loaded via a text widget in the top right sidebar isn't showing up?

    I know that's a lot, but you seem to have all the answers for this theme!

  11. Andrew
    Forum moderator
    Posted 1 year ago #

    If you create your own thread you'll be visible to everyone on this forum.

  12. jlevant
    Posted 1 year ago #

    Thank you Andrew. Just did.

  13. kwnwosu
    Posted 1 year ago #

    I have the same problem, but can't fix it with the suggestions shown in this thread. The sidebar displays properly on homepage, but not in post. I only have this problem in Internet Explorer not in safari or chrome.
    I have set content columns at 3, layout at "content sidebar"

    Have tried everything above but no succes, have also tried to remove al widgets and replace just one in sidebar top, still doesn't work.

    Strange thing is, when I change to theme to another one with content/sidebar, I have the same problem!

    site is:

  14. kwnwosu
    Posted 1 year ago #

    By the way, content columns set a 2 does work, but I really want 3 columns or 2 colums with 2/3 of area for content.

  15. Handoko
    Posted 1 year ago #

    Hi all, I wish I could help. But I'm not using this theme anymore. I suggest you to contact the author or use the support forum directly from the theme website:

  16. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @kwnwosu - per Andrew's post above, you need to start your own thread if you need help. Old threads are not a good place to post - http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    You can start a Pinboard thread here:


Topic Closed

This topic has been closed to new replies.

About this Topic