Support » Plugin: Contact Form 7 » Pinboard Theme

  • Resolved gaffnere


    hi there.

    for some reason, when using the pinboard theme, the “Your Email (required)” input box of the contact form is formatted differently from the other input boxes. it’s outline is darker. it also highlights when you type in text, unlike the other boxes.

    see: link.

    this is the code i’m using. should be fine.

    <p>Your Name (required)<br />
        [text* your-name] </p>
    <p>Your Email (required)<br />
        [email* your-email] </p>
    <p>Subject<br />
        [text your-subject] </p>
    <p>Your Message<br />
        [textarea your-message] </p>
    <p>[submit "Send"]</p>

    any idea what’s up with that?

Viewing 15 replies - 1 through 15 (of 16 total)
  • I really don’t know about any form problems here, but if you simply look at the CSS, the form CSS is not getting applied to the email blank. So you could try adding this to the CSS – preferably to custom CSS if you have that:

    	box-shadow:inset 1px 1px 5px rgba(0, 0, 0, .05);
    	border:#EEE 1px solid;
    	font-family:"Droid Sans", sans-serif;

    hi WPyogi!

    appreciate your help, thanks.

    i’m now working off this site. tried that code… didn’t work though.

    i simply installed the plugin & activated it. have used this plugin with other themes & the email input box appears the exact same as the other input boxes. i don’t understand why it should behave differently with this theme.

    Where did you put that code?

    I don’t know why it’s misbehaving either – looks like some CSS is missing (intentionally or not, I can’t tell).

    in pinboard theme…
    appearance > theme options > layout > custom css

    EDIT – this was my “explanation” of the problem – FWIW 🙂

    It looks like it works if you use “text” for the type – see your email sign-up form is okay – they type is text in that one. But if the type is email, it has no CSS here:

    input[type="text"], input[type="password"], textarea {
        background: none repeat scroll 0 0 #FCFCFC;
        border: 1px solid #EEEEEE;
        box-shadow: 1px 1px 5px rgba(0, 0, 0, 0.05) inset;
        color: #999999;
        font-family: "Droid Sans",sans-serif;
        font-size: 13px;
        padding: 1.5%;

    So that’s what I added above.

    I see what happened – why your CSS isn’t working:

    	box-shadow:inset 1px 1px 5px rgba(0, 0, 0, .05);
    	border:#EEE 1px solid;
    	font-family:&quot;Droid Sans&quot;, sans-serif;

    For some reason, those quotes are stripped out – see if typing them in there rather than pasting works.

    thanks for you help.
    ok now things are getting really weird. i actually noticed that too. so i have typed it out 3 times now. but keeps reverting back to original one.

    Yeah, I don’t know what’s the deal with that – ugh. Well try it at the bottom of the style.css file.

    ha. ok so i added both of your 2 suggestions to the css file. & still no dice. weeeeird. maybe it’s time for a new plugin.

    I just tested that CSS on a test site on Pinboard – and it DID strip out the code in Custom CSS – but not in the style.css file.

    I don’t see that code at all in your style.css file. Do you want to try it again? (Frustrating I’m sure 🙂 )

    thanks again for all of your effort!
    i was going to wash my hands with it tbh.

    but inspired by your persistance, i just tried the code again in the css file…
    and guess what?

    can’t thank you enough 🙂
    was such a stupid niggly thing but it looked really bad.

    cheers, WPyogi!!

    YAY!! Weird too. I totally understand – I’m a perfectionist about those kinds of things too. Glad we hit it enough times – LOL!


    I am also having this trouble on my site:
    Unfortunately I have not had any luck pasting the above code into the custom CSS. I am very new to wordpress so I could be missing something obvious. Anyone have any ideas?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Pinboard Theme’ is closed to new replies.