Support » Theme: Pilcrow » Pilcrow Theme update – missing featured headers!

  • Hi all.

    I did a bit of a search and couldn’t find this issue listed – maybe it’s just me!

    Anyway, I have a problem with the Pilcrow theme update which has me scratching my head.

    My blog ( has an overall featured image (two recumbent tricycles) which I use on a lot of the pages/pages but I also set specific featured images for some posts. These have now stopped displaying, I only get the two bikes (which is better than nothing, but not ideal).

    When looking at the dashboard I can see the featured image visible for the relevant pages but it doesn’t show up. For example, the post on Velomobiles should have (unsurprisingly) a picture of a velomobile at the top – but it doesn’t!

    I haven’t made any changes to the theme, it’s just magically switched off my page-or-post-specific featured image from displaying.

    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    I have a client who is having the exact same issue with this theme. I would love to know if you resolved this issue and if so, how it was resolved.

    I just received a message asking if I’d solved this issue – sorry for not getting back to this thread.

    The answer is yes, but in a rather random way. I saw somewhere else that the Featured Header size had to be 1000 pixels wide (the original size was 770×220, I believe, which was what was specified and what fitted the space properly). If I upload the Featured Header 1000x??? then it displays OK. Of course, all my old Featured Headers are the 770×220 size and I haven’t got round to updating them all (on 150+ blog pages) but it is something I shall do eventually.

    So there was a fix but it wasn’t anything to do with Plugins, etc, it was a change to the theme.

    Moderator Kathryn


    Automattic Happiness Engineer

    Hi there, for Pilcrow:

    The custom header dimensions are 770 by 200 for two-column and 990 by 257 for wide layouts.

    I do see your featured image at the top of this page, at 770px wide:

    If you’re still having trouble getting header images to show on specific pages or posts, please feel free to post the links here and I’ll be glad to have a look.

    That’s one of the ones I’d fixed with a 1000px header.

    An example of a series which should all have the same picture at the top (a map of my ride from Berlin to London) is here:

    The Featured Header is visible when I look in the Admin tools but it doesn’t display when you view the page normally.

    Moderator Kathryn


    Automattic Happiness Engineer

    Auntie Helen, would you mind sending me a link to one or two of the missing featured header images themselves so I can download and do some testing with them? They could be links to your media library, or you could use an upload service like or


    This is the header for my Berlin To London section of the blog:


    And this is the header for my Konstanz to Koblenz section

    Ko2Ko Header

    These are 770×200 pixels.

    The Velomobile header (which works) is 1000×377 pixels.

    As I said above, it was all working perfectly well with the smaller-sized headers before an update and then it stopped. I had made no changes to the blog layout at the time.

    Moderator Kathryn


    Automattic Happiness Engineer

    Thanks very much for these.

    I set both of the 770X200 images you provided as featured images on two sample pages of my Pilcrow test site, and they are both displaying in the header of those two pages, as expected.

    Here are the screenshots so you can have a look:

    Featured Image Test Automattic Theme Testing

    Featured Image 2 Automattic Theme Testing

    Here are a couple of troubleshooting questions/ideas:

    1. Have you made any tweaks to the theme files or CSS?

    2. You mentioned this earlier:

    I saw somewhere else that the Featured Header size had to be 1000 pixels wide

    Do you remember where you saw that – could you provide a link if possible?

    3. As Esmi suggested earlier, could you please try temporarily turning off all plugins, and seeing if this issue goes away? If it does, turn them back on one-by-one until the problem reappears and you’ve found the culprit.

    Hi Kathryn,

    Thanks for looking into this for me.

    It’s interesting that you are able to get the headers to show as I tried multiple times with no success.

    I did previously try disabling all the plugins but that didn’t help.

    I can’t remember where I found the hint about the Featured Image size being 1000 pixels, I spent quite a lot of time googling for an answer and just spotted that one somewhere random – sorry! When I tried it and it worked I was relieved there was an option.

    I’ve made very few changes to the theme files, just a small manual change for the menu header font size and to make the menu dropdown font not all caps. I have to re-edit the main CSS file every time (I haven’t worked out how to do a nested version that is automatically remembered, or whatever the terminology is) so when I did the original update to the newest Pilcrow theme, it was entirely as the basic theme when it stopped working. Subsequently I have just made my small font size change and that didn’t seem to affect the header not displaying issue.

    Moderator Kathryn


    Automattic Happiness Engineer

    (I haven’t worked out how to do a nested version that is automatically remembered, or whatever the terminology is)

    There are a couple of ways to do this – redoing your changes after every update must be a pain. 🙂

    Since you’re already using Jetpack, a simple way is to activate Jetpack’s Custom CSS module. This gives you a stylesheet editor right in the dashboard under Appearance > Edit CSS. You can then add your CSS, and it won’t be overwritten when you update the theme.

    Would you mind sending me a screenshot of the dashboard (admin) side, for one of your pages that’s not displaying your featured image, so I can have a peek and see if I notice anything unusual? Please include the entire browser window if you can. You may want to use a browser screenshot extension to make it easier to take a screenshot of everything on the page, even “below the fold.”

    Let me know how it goes.

    I’m not using Jetpakc, but was intrigued at the Featured Image size being shifted to 1000 pixels wide. At my current post,, and several others, I’ve been struggling to create custom banners with featured images in Pilcrow. It seems to work sometimes, and other times not, that the post actually “features” the featured image I’ve selected. IN a bit of a fit of desparation, I chose the featured image to be from a recent post on Malaysia Airlines flight, which is now the default. However, I’ve been having a huge problem customizing the posted image successfully, although the edited posts includes the image. Could the image be of an incorrect size? Why does this work sometimes, but other times not?

    Moderator Kathryn


    Automattic Happiness Engineer

    Hi ptolohead – I’d be happy to troubleshoot with you one-on-one. Would you mind starting a new thread so we can do that more easily?

    In your new thread, could you provide links to a few pages/posts where your featured image is correctly showing up, and a few where they aren’t?

    Header images should be at least 990 by 180 pixels.

    I’ll meet you in your other thread. Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Pilcrow Theme update – missing featured headers!’ is closed to new replies.