Support » Plugin: Pricing Deals for WooCommerce » Piece of garbage doesn’t even work.

  • Using the coupon discount it’s totally bugged and shows the price is deducted BUT ITS ACTUALLY NOT. Seriously?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author vark

    (@vark)

    If I’ve understood correctly, you’ve created a coupon discount which showed in part but did not carry through to the totals.

    This issue is likely a conflict between my plugin and another module.
    Suggest a *full module conflict test*:

    To track down a module conflict, please follow these steps ** PRECISELY **:
    (1) Install and activate a maintenance mode plugin (if desired)
    (2) Then, DO ALL (*at the same time*):
    (-) do a full site backup!
    (-) deactivate ***all*** plugins except Woo, my plugin (and maintenance mode plugin)
    (-) ** switch to a clean default theme like “twentynineteen” **
    — (This removes all other possible conflicts.)
    (-) turn off all deals except the one we are examining.

    (3) ** close your browser completely, retest in a fresh, clean browser session **
    (4) if good, add 1 module back in. ** Retest **
    (5) Repeat until conflict identified.

    ** This test depends on following the outlined steps fully. **

    Best,
    Vark

    (PS – If you do have a module conflict, it will likely boil down to choosing between the 2 conflicting modules…)

    “There has been a critical error on your website” after I removed the coupon feature. Will you fix this? It’s broken.

    Fixed when I changed back to Unit Price Discount.

    I’ll try the conflict process you suggested, although I don’t want to because it’s a live site.

    Plugin Author vark

    (@vark)

    Hi,
    The plugin functionality works on thousands of installations.

    Hence my suggestion for a full module conflict test.

    Please let me know how the full module conflict test goes.

    By module conflict do you mean plugin conflict?

    Plugin Author vark

    (@vark)

    module conflict = plugin conflict or theme conflict.

    My site is really messed up, critical errors that don’t work. What’s your email so you can fix this please?

    I don’t know if this helps:

    “An error of type E_ERROR was caused in line 118 of the file /var/www/wptbox/wp-content/plugins/woocommerce/includes/data-stores/class-wc-coupon-data-store-cpt.php. Error message: Uncaught Exception: Invalid coupon. in /var/www/wptbox/wp-content/plugins/woocommerce/includes/data-stores/class-wc-coupon-data-store-cpt.php:118
    Stack trace:
    #0 /var/www/wptbox/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(159): WC_Coupon_Data_Store_CPT->read(Object(WC_Coupon))
    #1 /var/www/wptbox/wp-content/plugins/woocommerce/includes/class-wc-coupon.php(129): WC_Data_Store->read(Object(WC_Coupon))
    #2 /var/www/wptbox/wp-content/plugins/woocommerce/includes/class-wc-coupon.php(117): WC_Coupon->read_object_from_database()
    #3 /var/www/wptbox/wp-content/plugins/sumosubscriptions/includes/class-subscription-coupon.php(392): WC_Coupon->__construct(‘buy3get1’)
    #4 /var/www/wptbox/wp-includes/class-wp-hook.php(287): SUMO_Subscription_Coupon::set_recurring_discount_amount(Array, 0, 2193, 0)
    #5 /var/www/wptbox/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #6 /var/www/wptbox/wp-content/plugins/sumosubscriptions/includes/class-subscription-factory.php(176): apply_filters(‘sumosubscr”

    Plugin Author vark

    (@vark)

    Hi,
    You sent this:
    #6 /var/www/wptbox/wp-content/plugins/sumosubscriptions/includes/class-subscription-factory.php(176): apply_filters(‘sumosubscr”

    The issue seems to be a conflict with a plugin still active ‘sumosubscriptions’.

    Where are you in the test instructions sequence, please?
    Need more precise details.

    If you’d like to email me, you can use my support channel at
    https://www.varktech.com/support/

    Best,
    Vark

    I’ve deleted your plugin completely as I don’t want it on my site anymore. My site is still not working correctly. I need sumo subscriptions so I won’t be getting rid of that.

    I will contact you there.

    Plugin Author vark

    (@vark)

    Issue update:
    Clearing the site cache solved the immediate functional issue.
    The customer is pursuing full module conflict testing in a staging site.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this review.