Support » Fixing WordPress » pictures in rss feed

  • Resolved jtclicker

    (@jtclicker)


    I have a photoblog, most of my posts are just pictures. The pics don’t show up in the rss feed. Any ideas how to ensure the feed contains the images? I’ve NOT got the ‘summary’ box ticked.

Viewing 9 replies - 1 through 9 (of 9 total)
  • any ideas…?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    We need more information. Like the URL of your blog and feed, for one.

    If it’s the one in your profile, at foundobjectsgallery.com, then it appears that your RSS feed does contain the images, as far as I can see. The content:encoded tag has the IMG tags just fine.

    You won’t see them in, for example, Firefox, but if you load the feed into a feedreader, the images should show up okay.

    Do you have hotlink protection enabled with .htaccess? That will prevent images from showing up in your feeds in other people’s feed readers.

    Also, images won’t show up if you are using excerpts (partial feeds) of your posts. Full feeds should show images.

    Thanks for the help everyone. I had a comment from a reader and I just got some more info. The problem seems to be on Mac/Safari that if you subscribe via the auto subscribe feature of safari the pics aren’ t there. But if you subscribe through the buttons on my page, they appear ok? Feed is http://www.foundobjectsgallery.com/bartender/feed . I’ll let it go though…

    Hello, can somebody tell me if the pictures in my feed are working for them? http://imagegag.com/wp-rss.php

    I cannot see them, but I can see images in other sites’ RSS feeds.

    I am set on full (not summary).
    I am set on UTF-8.
    When I upload the picture, I click the options, Show: “Full Size” and Link to: “None”

    I would really appreciate if someone could help me out here. Thanks.

    Oh, this is what the code says on one example image if that helps at all.

    <img src="http://imagegag.com/wp-content/uploads/2007/12/jesusapprovedteddybear.jpg" alt="Jesus Approved Teddy Bear" />

    Thank you very much!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    ImageGag: That’s not your correct feed link. This is:
    http://imagegag.com/?feed=rss2

    Secondly, yes, the images are in this feed. They are not in the other link you gave, because that’s the wrong URL.

    Hmm, now that I notice it, the links on my feed don’t seem to be working either.

    THANK YOU OTTO42! I feel like a dummy, but I’m a happy one!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘pictures in rss feed’ is closed to new replies.