Support » Plugin: Print-O-Matic » pictures are not printed

  • Resolved jpkarmatech

    (@jpkarmatech)


    After updating to WP 5.2.1 pictures are no longer printed.
    On the print-preview the pictures are shown correctly, but only a blanc picture with a border is printed.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor twinpictures

    (@twinpictures)

    Hoi!
    Seems to be working find on this end. Is this experienced only on a specific machine or browser? Could be just a browser-caching issue–try it while in private/incognito window.

    Hy
    Thanks for the prompt reply.
    The problem occurs with Firefox (since WP update 5.2.1) and this on two different computers.
    I have just tested it with Google Chrome and there it works properly, the same with IE.

    Plugin Contributor twinpictures

    (@twinpictures)

    Wow. you say it works in IE and not in Firefox. These are strange times, indeed.

    Which version of Firefox are you using? It is working find in FireFox 67.0 on this end.

    Maybe try updating to the release candidate of print-o-matic available on GitHub

    Plugin Contributor twinpictures

    (@twinpictures)

    wait, wait… you say a blank picture is being printed is it displaying ok on the print-page (the page that pops up before the print dialogue is triggered)? It might just be that you have the print images disabled in the FireFox print settings. Also, is this on a PC? If so, is the simplify page being used?

    Plugin Contributor twinpictures

    (@twinpictures)

    OK, I just did some testing, and you are correct, no matter what, the images on that page will not print. However, when we tested FireFox on another site, the images print with no problems.

    So there is something wonky going on your page.
    You are not using a child-theme, so I assume you also do not have a dev site that can be used for testing?

    Your best bet at this point would be to do some basic WordPress Troubleshooting:
    Turn off all plugins but print-o-matic, see if it prints in firefox. If so, turn your plugins back on one by one and test until you find the plugin that is causing this strange behaviour. If the images still do not print with all plugins disabled, then it’s most likely your theme. Test this by temporarily switching to a standard Twenty-Something theme.

    Report back with your findings.

    Fret not! We’ll get this resolved.

    Thanks for your support.
    The Firefox version is 67.0 (on a PC)
    Yes, print-page is ok, picture is shown.
    I am uing no child theme.
    By direct printing with simply page-function, it works – picture ist printed!
    By printing from print-page there is only a border with empty picture.
    It is funny that this problem occurs since a few days.
    The same problem on two other sites:
    https://www.yogalehrerausbildung.ch/2019/05/26/die-fuenf-umhuellungen-kosha-von-atma/
    and
    https://www.irisyoga.ch/2019/05/21/wie-man-die-lebenskraft-bewahren-kann-teil-3/
    I will now do further tests and do some basic WordPress Troubleshooting

    I have tested it now with a XAMPP-local intallation:
    All Plugins but Print-O-Matic turned off -> same problem
    Choosing of Theme Twenty-Nineteen -> same problem

    Plugin Contributor twinpictures

    (@twinpictures)

    It is funny – it works, the pictures are printet with Firefox.

    Plugin Contributor twinpictures

    (@twinpictures)

    Huzzah! I have got it… oh, guess I mean Eureka!

    The issue is simply that FireFox needs a bit more time to serve up the image before trigging the print dialogue window. This can be resolved by providing a bit of pause-before-print time.

    Dashboard > Settings > Print-O-Matic > Pause Before Print
    a value of 200 should do the trick.

    Give that a try and get back to me with your joy/no-joy.

    Super!
    With 200ms delay time it works now properly on all sites with Firefox !!!
    Thank you very much for your super support even on a sunday!

    Plugin Contributor twinpictures

    (@twinpictures)

    Happy I could help.
    Marking issue as resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘pictures are not printed’ is closed to new replies.