Support » Plugin: CataBlog » Picture to link to another page

  • jimERo

    (@jimero)


    Is there a way to make clicking on a thumbnail (only in certain categories/galleries) link to another page? I would like to have a general products page displaying images of categories and clicking on the categories link to each style page.

    http://wordpress.org/extend/plugins/catablog/

Viewing 15 replies - 1 through 15 (of 20 total)
  • mbrsolution

    (@mbrsolution)

    Hi jimERo have a look at this link especially part 5.

    I hope this puts you on the right track.

    Kind regards

    jimERo

    (@jimero)

    Hi mbrsolution,
    Thanks for the reply. I tried step 5. I put in an address in the link field and I used the shortcode in that step to make the template be gallery. When I had lightbox enabled, this step did not change the functionality. Still the title would link to the correct url but the lightbox would appear when clicking on the image. I tried disabling lightbox. Now when I clicked on the title it would link to the correct url (like before) and clicking on the image would link to the url of the image. Any ideas?

    mbrsolution

    (@mbrsolution)

    Hi jimERo have a look at this post and navigate towards the end of the post. You can read what Zach suggest, I am sure that will help you with your question.

    Kind regards

    jimERo

    (@jimero)

    I added those two files to the theme directory, and this did not help. I also tried adding navigation=”disable” into the shortcode. I thought this would disable anything from happening when you click on a thumbnail, but the lightbox still appeared. Any ideas?

    mbrsolution

    (@mbrsolution)

    Hi jimERo, do you have any cache plugin installed? Can you post here the template you are using plus the chortcode?

    Kind regards

    jimERo

    (@jimero)

    Hi mbrsolution,
    The template I am using is called ArtWorksResponsive. The short code is : [catablog category=”Products” template=”gallery” navigation=”disable”]

    jimERo

    (@jimero)

    before I was using [catablog category=”Products” template=”gallery”]

    mbrsolution

    (@mbrsolution)

    Hi jimERo I have added some more instructions on the link above. Can you check them and see if they help you. Also on the following shortcode

    [catablog category=”Products” template=”gallery” navigation=”disable”]

    Remove the navigation=”disable” option so it will look like the following

    [catablog category=”Products” template=”gallery”] Also remember to change the template to the new created template.

    Let me know if this helps you.

    Kind regards

    jimERo

    (@jimero)

    This is the shortcode I am using [catablog category=”Products” template=”products”] and this is the template of name “products” :

    <div class="catablog-row catablog-gallery">
    	<code><a href="%PERMALINK%" class="catablog-image" %LINK-TARGET% %LINK-</code>REL%>
    
    <img src="%IMAGE-THUMBNAIL%" alt="" />
    		<strong class="catablog-title">%TITLE%</strong>
    
    	div class="catablog-description">%DESCRIPTION%</div>
    </div>

    and the light box still appears when I click on a thumbnail image.
    this is a link to the site 01theone.com/development/products

    here is a link to show what the catablog library entry looks like http://01theone.com/development/wp-content/uploads/2013/07/screenshotZerone.png

    mbrsolution

    (@mbrsolution)

    Hi your link does not look like a proper link. Can you verify that it is a good link.

    Kind regards

    jimERo

    (@jimero)

    Yes i am verifying and here, sorry about that http://01theone.com/development/products/

    mbrsolution

    (@mbrsolution)

    Hi when you added

    I added those two files to the theme directory, and this did not help. I also tried adding navigation=”disable” into the shortcode. I thought this would disable anything from happening when you click on a thumbnail, but the lightbox still appeared. Any ideas?

    Did you add the proper php file into the two CataBlog files?

    Also in your template below,

    <div class="catablog-row catablog-gallery">
    	<code><a href="%PERMALINK%" class="catablog-image" %LINK-TARGET% %LINK-</code>REL%>
    
    <img src="%IMAGE-THUMBNAIL%" alt="" />
    		<strong class="catablog-title">%TITLE%</strong>
    
    	div class="catablog-description">%DESCRIPTION%</div>
    </div>

    You have an error, remove the <code> tag so that it looks like this.

    <div class="catablog-row catablog-gallery">
    <a href="%PERMALINK%" class="catablog-image" %LINK-TARGET% %LINK-REL%>
    
    <img src="%IMAGE-THUMBNAIL%" alt="" />
    		<strong class="catablog-title">%TITLE%</strong></a>
    
    	<div class="catablog-description">%DESCRIPTION%</div>
    </div>

    I hope this helps you.

    Kind regards

    jimERo

    (@jimero)

    Hi,
    Thanks for the reply. My template does not have that error, that was because of a mistake of how I pasted the code into this forum reply. When creating the files: I created a file called single-catablog-items.php and a file called taxonomy-catablog-terms.php in my theme’s directory, in the ArtWorksResponsive-Child folder. Should I have put this in the Catablog directory?

    mbrsolution

    (@mbrsolution)

    Hi try putting those files in the theme parent folder.

    Kind regards

    jimERo

    (@jimero)

    I put them there. I just made blank files, though, and saved them with those names that i posted above. That is the correct procedure? blank files

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Picture to link to another page’ is closed to new replies.