Support » Plugins and Hacks » picture of product not showing

picture of product not showing

  • I have tried many different themes and many of the product images are not displaying on their individual pages.
    They do display on the initial shop page, when you click on an item to go to its individual page, the box where the image is supposed to be is empty.
    Also all of the thumbnail images likewise are not displaying.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi papc4u,
    I had a similar problem when I uploaded my images from the backend via FTP. But when I added the product images through the “featured image” tool for each product, uploading them through WP’s media library, they showed up.
    How did you upload your images?
    Do you have a sample link/page we can view to help troubleshoot?

    I think i dropped the images into the wp program. I did not add them via ftp.
    The link to the website is:


    If that does not work for you, i could email you a screen image.

    Ok. Did you set a “featured image” for each product?

    On the page where you set up the product info and price, there is a Featured Image panel on the lower right side.
    That is where you set the product image.

    What you see on the “shop” page is the category images.

    Yes, that did work. Thank you very much!
    May I also ask one more thing… when the tags are shown next to the product, is there a way to hide the tags?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘picture of product not showing’ is closed to new replies.