WordPress.org

Support

Support » Installation » [Resolved] PHTML problems with localhost/wordpress

[Resolved] PHTML problems with localhost/wordpress

  • WebmistressM
    Member

    @webmistressm

    Im currently trying to install WordPress onto my own computer (Ubuntu Hardy Heron). I got all the way through the process with LAMP but now I get problems when accessing /localhost/wordpress to start installation:

    Instead of the index page, I get a prompt asking me whether to open or save the phtml file. How do I get around this?

    I did already try editing /etc/apache2/apache2.conf, adding the below lines to the bottom of the document:

    AddType application/x-httpd-php .php .phtml
    AddType application/x-httpd-php-source .phps

    Sadly this still yields the same results. 🙁 Any information would be appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    Open up a terminal window and run this

    sudo a2enmod php5

    That should let load up the php5 apache2 module.

    WebmistressM
    Member

    @webmistressm

    Oh dear. It says “this module does not exist”. Hmm…well that might be a clue. 😉

    I know PHP5 is installed

    WebmistressM
    Member

    @webmistressm

    Addendum

    I just followed these instructions from here:
    https://help.ubuntu.com/community/ApacheMySQLPHP

    “You may also need to actually enable it, by doing sudo a2enmod php5 followed by sudo /etc/init.d/apache2 restart. If sudo a2enmod php5 returns “$ This module does not exist!”, you should purge (not just remove) the libapache2-mod-php5 package and reinstall it. “

    That did help me get “http://localhost” to come back with “It works!” and “http://localhost/wordpress” to return the following error:

    “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.”

    …which is an entirely different problem. Thanks,Jan. 🙂

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    That’s not bad actually. You’ve gotten PHP5 installed not try (if you have not already):

    sudo apt-get install php5-mysql

    Just like before, you will have to restart apache2.

    WebmistressM
    Member

    @webmistressm

    Jan

    That sure worked. strange is that I checked to make sure php was installed and it was. Strange that it wouldnt “see” that until I used the command you just asked me to try.

    At any rate, everything is up and 2.7 is up. HOLY cats! The UI changes look fantastic.

    Mary

    sudo /etc/init.d/apache2 restart

    just restarted apache and worked right away for me

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] PHTML problems with localhost/wordpress’ is closed to new replies.