Support » Fixing WordPress » PHPSESSID Cookie

  • Hello,

    my page uses a PHPSESSID Cookie and I have no idea how to turn it off.
    The cookie appears even if I turn of all plugins and my webhost wrote that it might be a bug in wordpress. This is the WordPress code that sets the cookie:

    [www286 paulre]# grep "setcookie" ./ -rl
    ./wp-includes/pluggable-deprecated.php
    ./wp-includes/pluggable.php
    ./wp-includes/class-snoopy.php
    ./wp-includes/js/codemirror/codemirror.min.js
    ./wp-includes/comment.php
    ./wp-includes/option.php
    ./wp-admin/post.php
    ./wp-content/plugins/fresh-framework/framework/extern/ace/src-min-noconflict/mode-php.js
    ./wp-login.php

    Thanks for your help!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello!

    If cookies are enabled, PHP will use cookies for that and this PHPSESSID is the default name for the cookie responsible for handling sessions. You can change that name changing session.name in your php.ini file, but that shouldn’t be a concern for you.

    This question at stackoverflow has additional info.

    Feel free to ask other questions. If you don’t have any, please, mark your topic as “resolved” πŸ™‚

    Hi Felipe,

    thanks for your reply. I don’t want to change the name of the cookie but turn it off. Can you help me with that?

    This link has some options to turn it off, but it’s basically put session.use_cookies = 0 into your php.ini file.

    Hi,
    I changed session.use_cookies = 1 to session.use_cookies = 0 in the php.ini file but the PHPSESSID cookie is sill there πŸ™
    Do you have any idea what I can do?

    Hello,

    has anyone an idea how I can get rid of this cookie?

    Please help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHPSESSID Cookie’ is closed to new replies.