Support » Fixing WordPress » phpmyadmin to ‘activate’ plugins who can’t be activated in options ?? hacktivate

  • Try to contain yourself. I signed up for ‘free’ hosting on tripod.co.uk. Yes, apparently frought with problems but I don’t want to wait around for the flybynight sites I signed up with.

    ok…

    I cannot click “activate” in the plugins menu. Thank tripod for their evil frame scheme. I can load the admin pages by apending a “?” to the url

    example this:
    http://members.lycos.co.uk/me/wp-admin/plugins.php

    becomes this:
    http://members.lycos.co.uk/me/wp-admin/plugins.php?

    Please please tell me there’s a manual way to hack-tivate plugins on difficult hosts! What can be done with PHPmyadmin? Some null file I can upload?

    :sigh:

    I’m trying to hacktivate SpamKarma2 so that my blog won’t become easy pickings for spammers 🙂

    thanks el mucho!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Mark (podz)

    (@podz)

    Support Maven

    There will be a way, but the syntax in the database for activated plugins is very very strange. Really.
    Can you activate anything ? If so, go get bad-behavior:
    http://www.ioerror.us/software/bad-behavior/
    as that will protect you from almost everything.

    Nope, I can’t activate anything. Having read a few more plugin posts for a few hours I found

    wp_options
    active_plugins

    and it contains only:

    a:1:{i:0;s:0:””;}

    googling for that was entertaining, but I have noooo idea what to type in to activate SpamKarma

    Mark (podz)

    (@podz)

    Support Maven

    a:2:{i:0;s:0:”
    “;i:1;s:27:”SK2/spam_karma_2_plugin.php”;
    i:2;s:39:”bad-behavior/bad-behavior-wordpress.php”;
    }

    That may work – it’s from my install.

    (The a = no. plugins installed, the first i and s I have no clue, then it is i for plugin number and the s is the number of characters in the plugin name. Told you it was wierd!)

    Mark (podz)

    (@podz)

    Support Maven

    Oh – put it all on one line, no gaps…

    sweet! thanks!!

    the first few times I entered

    a:2:{i:0;s:0:””;i:1;s:27:”SK2/spam_karma_2_plugin.php”;}

    tripod came back with “invalid data type in array”. But I repeated it a few more times and it stuck. Maybe there was a delay between my first change (your string) and my shortened string?

    I won’t be able to change any of the settings, but the defaults are plenty good.

    God bless you!!

    for the curious here’s the error:

    Warning: in_array(): Wrong datatype for second argument in /data/members/free/tripod/uk/s/t/a/me/htdocs/wp-admin/plugins.php on line 87

    SK really really prefers to be in ./SK2/

    a:2:{i:0;s:0:””;i:1;s:27:”SK2/spam_karma_2_plugin.php”;}

    than ./

    a:2:{i:0;s:0:””;i:1;s:27:”spam_karma_2_plugin.php”;}

    Mark (podz)

    (@podz)

    Support Maven

    Was SK2 uploaded as a complete directory ?
    That looks as if the plugin file was uploaded to /plugins, whereas when you open /plugins you should only see /SK2

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘phpmyadmin to ‘activate’ plugins who can’t be activated in options ?? hacktivate’ is closed to new replies.