Support » Localhost Installs » phpMyAdmin

  • Resolved mistere5

    (@mistere5)


    I created a new database using phpMyAdmin but when I try to login I keep getting the same error – saying that the database or password is incorrect.
    I get the following message:

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can not contact the database server at localhost. This could mean your host’s database server is down.

    Are you sure you have the correct username and password?
    Are you sure you have typed the correct hostname?
    Are you sure the database server is running?
    If you’re unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    I just created it. I tried it with both as a username with password and as root without a password.

    Can anyone advise me how I can proceed?
    I have tried watching various YouTube Videos and followed it to the letter without success.

    • This topic was modified 2 months ago by mistere5.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Dion Designs

    (@diondesigns)

    Does the WordPress database user have access to the database? That’s done by clicking the User Accounts tab in phpMyAdmin, then clicking the Edit Privileges icon for the DB user. If the user has global privileges to all databases (the root user for example), then you have a different problem…perhaps a missing or incorrectly-specified password, or perhaps an incorrect WordPress setting for DB_HOST.

    If the user has no global privileges, then click the Database button that’s just below the tab bar. Now select the database you just created and click Go, then tick the Check All box and click Go. You should now be able to access the database.

    Please allow me to add to Dion Designs’s answer above.

    Since the error message also refers to WordPress, I suppose you are not having trouble with phpmyadmin but rather installing WordPress.

    Did you put in db info in wp-config.php correctly?

    https://wordpress.org/support/article/editing-wp-config-php/

    mistere5

    (@mistere5)

    I found a solution. I uninstalled Wamp Server and all it’s files and installed Local by Flywheel.

    Thank you for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.