Support » Fixing WordPress » PHP.INI Problem Not Allowing 20MB File

  • Resolved arickrol


    I am trying to upload a 20MB video file to my blog. Each time I try I receive the following error message:

    This file is too big. Your php.ini upload_max_filesize is 2M.

    I have changed my php.ini file (located in the root at /public_html because that’s where my WP is installed) so that the following is how it reads:

    ; Maximum size of POST data that PHP will accept.
    post_max_size = 100M


    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 100M

    I have cleared my browser (Safari) cache twice, closed out of the browser and gone back into it. None of this has worked. What else could be causing the problem and how do I resolve this?

    What other information is necessary? I’m using BlueHost for hosting, I’m on WP 2.7.1.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The php.ini file is not recursive so it is actually needed in the uploads folder or whatever other folders are involved in getting that file uploaded, however, I would suggest just keeping that file in your public_html and enabling the single php.ini mode. In your BlueHost cPanel, go to the Software/Services section and click on PHP Config. Once in there, change your php to php5 (Single php.ini). Doing so should make your settings change to the php.ini in your public_html work for all your subfolders which need those settings.

    BernardBorealis: That fixed it. I totally flaked on the recursive issue. Thanks for the reminder and the quick fix in BlueHost. I greatly appreciate it. I believe we can consider this issue RESOLVED.

    I’ve got quite a similar problem, only with the ‘time out’ during importing posts.
    I’m also on bluehost. I’ve copied the php.ini file into the _public directory, changed the config to ‘single php.ini’ and changed the following settings:
    max_execution_time = 90
    max_input_time = 300
    memory_limit = 32M
    post_max_size = 8M
    upload_max_filesize = 8M

    I know the server uses the file, since the max upload file size in wordpress has changed from 2MB to 8MB.
    The first 2-3 files (about 2-3MB each) weren’t a problem, but from there on, the number of posts imported before the timeout decreased… now the server times out every time during import, not even able to import 1 new post. In total I’ve got about 4500 posts imported already, another 5500 to go.

    What other settings should I change? I’m using WP 2.7.1

    What is the size of the file you are trying to import? Increase your post_max_size and your upload_max_size to make sure they are larger than the file you are importing. Try increasing your memory limit a little, too. There may be something corrupt in your imported file which is causing it to hang.

    All done, tried it with:
    max_execution_time = 600
    max_input_time = 600
    memory_limit = 128M
    post_max_size = 64M
    upload_max_filesize = 64M

    The file is only 2.5MB, so it shouldnt be a problem. I also changed the
    “set_time_limit(60)” (in the wordpress.php, the file used by wordpress to upload) into “set_time_limit(600)”.
    But nothing seems to work. Emptyed my database through mysql. Even with an empty database it times out somewhere between 30-60sec. Just able to import around 300 posts.

    I don’t get a error message or something…it just stops..

    Even changed all the mysql ‘time’ settings in the php.ini file to either 600sec or inifinite.
    Still WordPress times out after 60sec. I’m busy with this problem for about 2 days now, just can’t figure it out.. really need some help!!!!

    mysql is now suspect number 1: “GLOBAL wait_timeout = 60”
    but I don’t seem to have acces to change it..
    anybody an idea?

    add this to top of wp-config.php and let me know if it helps by contacting me here [link moderated]
    define(‘WP_MEMORY_LIMIT’, ’64M’);

    I am with BlueHost too. I just put up a new blog and I had the same problems when I tried to put a video on it. I made my memory_limit = 100M, upload_max_filesize = 100M, max_execution_time = 600. These are the changes I made to the php.ini file in my public html folder. Then I change my php to php5 (Single php.ini). This did not work so I changed back to php5. Then I copy the php.ini file and put a copy in the wp-admin folder of my new blog. That worked. The blog is not finished yet but the video is working. If you would like to see the video working go to:

    I’m at Bluehost and I want to upload bigger video files also, but there is no php.ini file. Should I create one? I’ll make the cPanel changes, but I need to first get a php.ini file. Where do I get one to start?
    Any ideas?


    In the cPanel use the PHP Config icon to install the master/default php.ini file. Once installed it will appear in your public_html directory, however it will be named php.ini.default, so you’ll have to rename it to php.ini.

    Also in the PHP Config section is the option to set your php mode to PHP5 (Single php.ini). You’ll want to set that and save it while you’re there as well.

    Very helpful! Thank you all!

    This post was a life-saver. Thanks!

    I am so confused. I need help!

    I went to file manager in godaddy and this is waht my php.ini looks like

    register_globals = off
    allow_url_fopen = off
    expose_php = Off

    max_execution_time = 600
    max_input_time = 600
    memory_limit = 128M
    post_max_size = 64M
    upload_max_filesize = 64M

    variables_order = “EGPCS”
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP =
    url_rewriter.tags = “a=href,area=href,frame=src,input=src,form=,fieldset=”


    I am trying to import a file that is 31.4MB. When I try to import it, it says

    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    I have been trying to import posts for weeks now and am stuck. help!!

    on godaddy, I also have this line in my php.ini (I’m not sure it’s important…but it’s a place to start)
    file_uploads = On

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘PHP.INI Problem Not Allowing 20MB File’ is closed to new replies.