Support » Plugin: Styles » PHP7 non-compatibility

  • Resolved davidbe929

    (@davidbe929)



    I am forced to upgrade to PHP7 in January but PHP Compatibility Checker reports the following errors for the Style plugin:

    FILE: wp-content/plugins/styles/classes/csstidy/class.csstidy.php
    249 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7

    FILE: wp-content/plugins/styles/classes/csstidy/class.csstidy_optimise.php
    50 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7

    FILE: wp-content/plugins/styles/classes/csstidy/class.csstidy_print.php
    69 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7

    FILE: wp-content/plugins/styles/classes/styles-font-menu/classes/markdown/markdown.php
    223 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7

    Is there any chance for an update to make styles PHP7 compatible by the end of the year?

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP7 non-compatibility’ is closed to new replies.