Support » Plugin: Ebook Store » PHP7 issues

  • Resolved Barn2Media

    (@barn2media)


    Hi, I want to upgrade my server to PHP7 and am getting lots of errors relating to eBook Store when I run the site through WP Engine’s PHP7 compatibility checker. Please could you provide a fix:

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/fpdi/fpdf.php
    ————————————————————————————————————
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    ————————————————————————————————————
    76 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1055 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ————————————————————————————————————

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/filters/FilterLZW.php
    —————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————–
    147 | ERROR | Bitwise shifts by negative number will throw an ArithmeticError in PHP 7.0
    —————————————————————————————————–

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/filters/FilterLZW_FPDI.php
    ———————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————-
    26 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————————-

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/filters/FilterASCII85_FPDI.php
    ————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————–
    26 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ————————————————————————————————————–

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/fpdi_pdf_parser.php
    —————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————
    69 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/pdf_parser.php
    ———————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————-
    101 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————-

    FILE: /nas/content/live/kulindaltd/wp-content/plugins/ebook-store/includes/fpdi/pdf_context.php
    ———————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————–
    40 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————–

    Many thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author motov.net

    (@motovnet)

    Hello,

    Thank you for your valuable feedback, fix is coming asap! Day or two max.

    Thanks again!

    Barn2Media

    (@barn2media)

    Brilliant, thank you so much

    Plugin Author motov.net

    (@motovnet)

    Hello,

    I’ve checked and it works properly on PHP 7, the critical errors are in legacy files not really in use at least according to my tests.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP7 issues’ is closed to new replies.