Support » Plugin: Events Manager » php7 errors

  • Hi with the php7 compatibility checker the plugin found two errors to use php7:

    FILE: …plugins/events-manager/em-shortcode.php
    ————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————-
    113 | ERROR | ‘clone’ is a reserved keyword introduced in PHP version 5.0 and cannot be invoked as a function (T_CLONE)
    ————————————————————————————————————————-

    FILE: …/plugins/events-manager/classes/em-object.php
    —————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————
    1177 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    NetWebLogic Support

    I get this too, I’ve let the devs know about it. should get fixed soon.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi, sorry for the delayed replies, a way overdue update is scheduled for next week which fixes all reported PHP 7 errors and warnings. The dev version is a RC, considered stable and already available to try:

    http://wp-events-plugin.com/documentation/upgrade-dev-version/

    mustermann

    (@mustermann)

    Hi Marcus,

    This are good news, that next week the plugin will be a new official version without any PHP 7.1 errors.

    Thank you for help.
    mustermann

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘php7 errors’ is closed to new replies.