Support » Plugin: MailChimp for WordPress » PHP7 error

  • Resolved Barn2Media

    (@barn2media)


    ​Hi, I need to update my server to PHP7 and there are errors with the Pro version of MailChimp for WordPress when I run WP Engine’s PHP7 compatibility checker, please could you fix these. The errors are:

    FILE: /nas/content/live/facesandplaces/wp-content/plugins/mc4wp-premium/logging/views/admin-reports-log_item.php
    —————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————-
    151 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    —————————————————————————————————————-

    FILE: /nas/content/live/facesandplaces/wp-content/plugins/mc4wp-premium/logging/includes/class-log-table.php
    ————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————–
    170 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    ————————————————————————————————————–

    FILE: /nas/content/live/facesandplaces/wp-content/plugins/mc4wp-premium/logging/includes/class-dashboard-log-widget.php
    ———————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————–
    60 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    ———————————————————————————————————————–

    Many thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hello @barn2media,

    Our plugin is compatible with PHP7. But since we need to support customers who are still using older versions of PHP, our plugin is backwards compatible which is why you see the warnings. You can safely ignore them. A better way to test for bugs with PHP7 would be to enable “WP_DEBUG”.

    Brilliant, thanks very much

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP7 error’ is closed to new replies.