Support » Plugin: CP Contact Form with PayPal » PHP7 compatible?

  • Resolved FreshIdeaWebsites

    (@freshideawebsites)


    A compatibility plugin suggests that there are 2 issue identified which make the current version (v509) non-php7 compatible.
    Are there plans to address these issues?

    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    —————————————————————————————————————
    849 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    1369 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————————

    FILE: /public_html/wp-content/plugins/cp-contact-form-with-paypal/captcha/captcha.php
    ———————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————–
    16 | ERROR | Function session_register() is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SESSION instead
    ———————————————————————————————————————–

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author codepeople

    (@codepeople)

    Hi,

    That code is from a very old version of the plugin. Please be sure to update to the latest version to get the updated code.

    In the case you are using a commercial version of the plugin and need help about the update then please post a ticket at https://cfpaypal.dwbooster.com/contact-us

    Thank you.

    Thx. The WP plugin page didn’t indicate that an update was available, but you were right…there is a newer version (and yes, its the PRO version). I downloaded v5.2.36 from the link provided (and assume this is the most recent version). Unfortunately the compatibility scan still indicates 2 errors. One diff from the first scan (line 971 in cp_contactformpp.php), but the second is the same as the first scan results (line 16 in captcha.php).

    FILE: /home/demo/generic.freshideademo.com/wp-content/plugins/cp-contact-form-with-paypal/cp_contactformpp.php
    ————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————–
    971 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————–

    FILE: /home/demo/generic.freshideademo.com/wp-content/plugins/cp-contact-form-with-paypal/captcha/captcha.php
    ———————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————–
    16 | ERROR | Function session_register() is deprecated since PHP 5.3 and removed since PHP 5.4; Use $_SESSION instead
    ———————————————————————————————————————–

    Plugin Author codepeople

    (@codepeople)

    Hi,

    Latest version of the Professional version (the version you are using) is #5.2.38

    Please use again your personal download link and be sure that after installed the version number that appears in the plugins area is 5.2.38.

    Installation/update instructions:

    http://wordpress.dwbooster.com/faq/general-questions#q94

    Thank you.

    Great. Thx for the quick response. v5.2.38 (Feb24) now correctly passes PHP7 compatibility tests.
    Again, apprec’t the fast service!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP7 compatible?’ is closed to new replies.