Support » Plugin: AceIDE » PHP7 Compatibility – possible issues to be fixed

  • A check for compatibility with PHP 7.0 using the “PHP Compatibility Checker” plugin,
    reports the following errors and warnings.

    FILE: /home/sitename/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Crypt/Random.php
    ———————————————————————————————————————————
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
    ———————————————————————————————————————————
    65 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    65 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
    104 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    104 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; use OpenSSL instead
    ———————————————————————————————————————————

    FILE: /home/sitename/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Crypt/Base.php
    ———————————————————————————————————————————-
    FOUND 0 ERRORS AND 39 WARNINGS AFFECTING 20 LINES
    ———————————————————————————————————————————-
    777 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    777 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    810 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    810 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    813 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    813 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    818 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    818 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    827 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    827 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    837 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    837 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    840 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    840 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    1089 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1089 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    1117 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1117 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    1122 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1122 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    1131 | WARNING | Function mdecrypt_generic() is deprecated since PHP 7.1; use OpenSSL instead
    1134 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1134 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    1596 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1596 | WARNING | Function mcrypt_list_algorithms() is deprecated since PHP 7.1; use OpenSSL instead
    1675 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1675 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
    1676 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1676 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
    1681 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1681 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; use OpenSSL instead
    1795 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1795 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
    1796 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1796 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
    1802 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1802 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; use OpenSSL instead
    1807 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1 – use openssl (preferred) or pecl/mcrypt once available instead.
    1807 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; use OpenSSL instead
    ———————————————————————————————————————————-

    FILE: /home/sitename/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php
    ——————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————-
    182 | ERROR | Global with variable variables is not allowed since PHP 7.0
    ——————————————————————————————————————-

    FILE: /home/sitename/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/File/X509.php
    ————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————-
    4387 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4412 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4479 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4551 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ————————————————————————————————————-

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    We are running WP 4.8.1 on PHP7.0 .
    We did another scan of this plugin using PHP Compatibility Checker, and found some possible incompatibilities, shown below.
    We have supplied these to you in case there is a problem.
    If these are a problem, and you know that this plugin is fully compatible with PHP7, then it would be helpful to add this plugin’s name to the PHP compatibility whitelist.

    Name: AceIDE

    FILE: /home/WebSiteName/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php
    ——————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————-
    182 | ERROR | Global with variable variables is not allowed since PHP 7.0
    ——————————————————————————————————————-

    FILE: /home/WebSiteName/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/File/X509.php
    ————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————-
    4387 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4412 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4479 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4551 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4

    I ran a scan using PHP Compatibility Checker and it generated the following report for compatibilty with PHP7;

    Name: AceIDE

    FILE: /home/markkend/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Crypt/Random.php
    ——————————————————————————————————————————-
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
    ——————————————————————————————————————————-
    65 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    65 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; Use OpenSSL instead
    104 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    104 | WARNING | Function mcrypt_create_iv() is deprecated since PHP 7.1; Use OpenSSL instead
    ——————————————————————————————————————————-

    FILE: /home/markkend/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Crypt/Base.php
    ——————————————————————————————————————————–
    FOUND 0 ERRORS AND 39 WARNINGS AFFECTING 20 LINES
    ——————————————————————————————————————————–
    777 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    777 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    810 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    810 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    813 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    813 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    818 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    818 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    827 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    827 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    837 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    837 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    840 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    840 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    1089 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1089 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    1117 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1117 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    1122 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1122 | WARNING | Function mcrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    1131 | WARNING | Function mdecrypt_generic() is deprecated since PHP 7.1; Use OpenSSL instead
    1134 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1134 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    1596 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1596 | WARNING | Function mcrypt_list_algorithms() is deprecated since PHP 7.1; Use OpenSSL instead
    1675 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1675 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; Use OpenSSL instead
    1676 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1676 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; Use OpenSSL instead
    1681 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1681 | WARNING | Function mcrypt_module_close() is deprecated since PHP 7.1; Use OpenSSL instead
    1795 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1795 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; Use OpenSSL instead
    1796 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1796 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; Use OpenSSL instead
    1802 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1802 | WARNING | Function mcrypt_module_open() is deprecated since PHP 7.1; Use OpenSSL instead
    1807 | WARNING | Extension ‘mcrypt’ is deprecated since PHP 7.1; Use openssl (preferred) or pecl/mcrypt once available instead
    1807 | WARNING | Function mcrypt_generic_init() is deprecated since PHP 7.1; Use OpenSSL instead
    ——————————————————————————————————————————–

    FILE: /home/markkend/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php
    ——————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————-
    182 | ERROR | Global with variable variables is not allowed since PHP 7.0
    ——————————————————————————————————————-

    FILE: /home/markkend/public_html/wp-content/plugins/aceide/vendor/phpseclib/phpseclib/phpseclib/File/X509.php
    ————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————-
    4387 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4412 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4479 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    4551 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ————————————————————————————————————-

    Plugin Author shanept

    (@shanept)

    Hi there,

    Sorry for not getting back to you on this one at all.
    The issues in question are with a library that AceIDE consumes. The only options we have are to update or to get rid of it. I’ve checked out the library and it looks like it still violates some of the same rules.

    This library has a very, very small role in the plugin, and I do not see any requirement for it. I shall be removing it by the next release, and opting for replacing the functionality with pure PHP with the OpenSSL module.

    Thank you for this report. Together, we will make AceIDE better!

    MKSnMKS

    (@mksnmks)

    Thanks for the info.
    Please let me know then that is done, and I will mark this topic as resolved.

    Thank you

    Plugin Author shanept

    (@shanept)

    Hi MKSnMKS,

    I have committed the code to make this compatible with PHP 7.
    It will be available as of the next stable release.

    Kind Regards,
    Shane Thompson

    MKSnMKS

    (@mksnmks)

    Hi Shanept,

    Thanks for the update. Please let me know when the fix has made it into a release, and then we can mark this as resolved.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘PHP7 Compatibility – possible issues to be fixed’ is closed to new replies.