Support » Plugin: All-in-One WP Migration » PHP7 Compatibility

  • Resolved LPP_DEV

    (@lpp_dev)


    Using the PHP Compatibility Checker plugin I got this error log for the current version of All In One when testing for PHP7 compatibility:

    FILE: /home2/thesali1/public_html/wp-content/plugins/all-in-one-wp-migration/lib/vendor/servmask/database/class-ai1wm-database-mysql.php
    —————————————————————————————————————————————-
    FOUND 9 ERRORS AFFECTING 9 LINES
    —————————————————————————————————————————————-
    35 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    45 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    54 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    63 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    72 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    82 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    92 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    102 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    112 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    —————————————————————————————————————————————-

    Thoughts?

    Thanks!
    John

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Borislav Angelov

    (@bangelov)

    Hi

    All in One WP Migration is fully compatible with PHP 7 and PHP >= 5.2

    You probably see these errors, because we support PHP >= 5.2

Viewing 1 replies (of 1 total)
  • The topic ‘PHP7 Compatibility’ is closed to new replies.