Support » Plugin: YouTube for WordPress » PHP7+ compatibility

  • Resolved Sibbo100

    (@sibbo100)


    Hi Support,

    Can you confirm if this plugin is fully compatible with PHP7+

    Thank you
    Sibbo100

Viewing 4 replies - 1 through 4 (of 4 total)
  • Also when seeing WP_Debug to true I get the following error:

    Fatal error: Cannot unset $this in /home/stagefm/public_html/wp-content/plugins/wp2yt-uploader/classes/class.youtube-for-wordpress.php on line 32

    Thanks

    Any one know if this plugin is PHP7.2 compatible, when I upgrade my version of PHP on the server using this plugin I get an HTTP 500 error and I know it is this plugin and another that is causing the crash as I have WP_DEBUG on in my config.

    Thank You
    Sibbo100

    Plugin Author Evan Herman

    (@eherman24)

    Hi @sibbo100,

    I’m not entirely sure as I haven’t touched this plugin in some time. It’s possible YouTubes API has changed or something internally needs updating for PHP 7+.

    Evan

    Hi @eherman24 ! There is a fatal error in >= PHP 7.1 that is pretty simple to fix:

    Cannot unset $this in wp-content/plugins/wp2yt-uploader/classes/class.youtube-for-wordpress.php on line 32

    This is because of the “Do not call destructors on incomplete objects” change mentioned here

    I think just removing the entire __destruct function should be fine in this case. Do you think you could commit a fix and release an update? Otherwise I would be happy to do it if you grant me commit access.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP7+ compatibility’ is closed to new replies.