Support » Plugin: Mathilda » PHP warnings on Mathilda 0.11

  • Resolved ArtGoddess

    (@artgoddess)


    Hi there,

    Nice plugin!

    I can see these warnings in a WordPress site using

    PHP 8
    Wordpress 5.6.2
    Mathilda 0.11

    Warning: Undefined array key 0 in /home/server/public_html/domain.com/wp/wp-content/plugins/mathilda/mathilda_painting.php on line 525
    
    Warning: Trying to access array offset on value of type null in /home/server/public_html/domain.com/wp/wp-content/plugins/mathilda/mathilda_painting.php on line 525

    Just in case it helps. Many thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author unmus

    (@unmus)

    Thank you very much for reporting of this.
    I will keep it on my list.

    Just to be sure, but I assume you are aware of the following. You can avoid these messages, if you decrease your logging level of php or wordpress.

    Plugin Author unmus

    (@unmus)

    Thread Starter ArtGoddess

    (@artgoddess)

    Many thanks @unmus

    In fact when I decrease the number of Tweets on Page below my overall number of tweets, the warning disappears. So it is not urgent. Many thanks for taking care of your nice script. 🙂

    Plugin Author unmus

    (@unmus)

    This is an important hint.
    Could you give me the threshold?
    How many tweets have you displayed, as this message comes up?

    Thread Starter ArtGoddess

    (@artgoddess)

    200 tweets have been imported.

    If I set up 56 or more “Tweets on Page” I can see the warning.

    55 or less, no warning.

    Plugin Author unmus

    (@unmus)

    Thank you!
    I will look into it at the weekend.

    Plugin Author unmus

    (@unmus)

    Could you please switch to PHP 7.x and check, if the warnings still appear?

    Thread Starter ArtGoddess

    (@artgoddess)

    Hello @unmus,

    When I reported this issue I was running PHP 7.4.

    Now:
    All plugins deactivated except Mathilda,
    Loading Tweets with API,
    PHP 7.4,
    WP 5.7,
    Mathilda 0.11,
    another twitter account (128 tweets, 35 hashtags, 48 mentions, 24 media import, 35 URLs, first tweet 2009):

    Everything imported, but same behaviour regarding warning.

    If I set up 21 or more “Tweets on Page” I can see the warning.

    20 or less, no warning.

    I’m working on the website, and it is not public yet, for this reason I have DEBUG mode enabled. Consider it because maybe the warning with debug mode off it doesn’t appear.

    Many, many thanks for your time.

    • This reply was modified 10 months, 2 weeks ago by ArtGoddess.
    Plugin Author unmus

    (@unmus)

    Hello @artgoddess.

    Currently I cannot reproduce the error with my wordpress instance, which matches your environment in the versions of WordPress, PHP and the plugin.

    I assume the error will not caused by the amount of tweets displayed on the page. The warning indicates on a function, which is responsible to prepare the rendering of tweets with images. So I think, there is an issue with some of your tweets with images. If you reduce the number of tweets to 20 on one page, you should get the error on one of the next mathilda pages. Could you check this?

    As next step I will load your provided data into my environment. Hopefully I can it reproduce it then. Please give me some time for this. The next days I am overloaded with other obligations. But perspectivly end of the months I will analyse it further.

    Thank you again for reporting.

    Thread Starter ArtGoddess

    (@artgoddess)

    Many thanks @unmus for your reply.

    Today I’ve tweeted and tweet has been imported flawlessly. Whilst I haven’t modified the 21, no warning on first page, but now the warning appears in second page. The same if I change the value to 20.

    This is not urgent at all, so, please, don’t bother. Really.

    Thanks again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PHP warnings on Mathilda 0.11’ is closed to new replies.