• Resolved Kevin Pfeifer


    Dear Community,

    since last plugin update or so i get these warnings in backend.

    Warning: rename(<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/location/where.php,<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/location/where-1_8_4.php): No such file or directory in <my-hoster-path>/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 675
    Warning: copy(<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/location/where.php): failed to open stream: No such file or directory in <my-hoster-path>/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 676
    Warning: rename(<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/event/location.php,<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/event/location-1_8_4.php): No such file or directory in <my-hoster-path>/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 688
    Warning: copy(<my-hoster-path>/wp-content/themes/dasvok/plugins/events-manager/forms/event/location.php): failed to open stream: No such file or directory in <my-hoster-path>/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 689

    PHP 7.2
    Wordpress 5.0.2
    Events Manager 5.9.5
    OpenStreetMap Plugin 1.8.4

    Warnings disappear when i deactivate the plugin and they stay hidden for “some time”.

    I cant reproduce the steps what to do to get the error, but after some time (or some specific steps i haven’t found yet) the warnings reappear.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Stonehenge Creations


    Reload page also removes the warnings. They are only there the very first time. So “for some time” is until you create a new database. 😉

    Upon activation the plugin tries to update the template files in your theme folder. Once that is done, the warnings are gone.

    Btw, you only see this when your debugging mode is on.

    Thread Starter Kevin Pfeifer


    Reloading the page didn’t fix the problem for me. Event after a few minutes.

    Debugging Mode is also disabled on my page.

    But now they aren’t present for me so i will wait a few days if they reappear.

    Thanks for the quick response!

    Thread Starter Kevin Pfeifer


    Yes you are right.

    I didn’t see the “plugin” directory in my theme after installing the plugin.

    My current setup overwrites the whole theme folder every time i change something in SASS, JS or other source files.

    That was the reason why i got these warnings.

    Plugin Author Stonehenge Creations


    Hehe… That explains it.
    I am however rewriting the plugin check, just in case 😉

    That should stop the warnings, even in your case! 😀

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP Warnings in WP Backend’ is closed to new replies.