Support » Plugin: IP2Location Country Blocker » PHP Warnings flooding error_log after recent update

  • Resolved Zebulan Stanphill

    (@zebulan)


    After a recent update to this plugin (not sure which), my site’s PHP error_log has been spammed with warnings just like these every 1 minute.

    [18-Nov-2021 02:34:02 UTC] PHP Warning:  Cannot modify header information - headers already sent in /home/MYSITE/public_html/wp-content/plugins/ip2location-country-blocker/ip2location-country-blocker.php on line 1656
    [18-Nov-2021 02:34:02 UTC] PHP Warning:  Cannot modify header information - headers already sent in /home/MYSITE/public_html/wp-content/plugins/ip2location-country-blocker/ip2location-country-blocker.php on line 1657
    [18-Nov-2021 02:34:02 UTC] PHP Warning:  Cannot modify header information - headers already sent in /home/MYSITE/public_html/wp-content/plugins/ip2location-country-blocker/ip2location-country-blocker.php on line 1658
    [18-Nov-2021 02:34:02 UTC] PHP Warning:  Cannot modify header information - headers already sent in /home/MYSITE/public_html/wp-content/plugins/ip2location-country-blocker/ip2location-country-blocker.php on line 1659

    The issue seems to stem from the header() calls in ip2location-country-blocker.php at lines 1656-1659.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ip2location

    (@ip2location)

    It seems like there is output sent before running our plugin.

    Can you send us an email to support [at] ip2location.com with your website URL and also the full error log?

    Thread Starter Zebulan Stanphill

    (@zebulan)

    There were no other messages in the error log that accompanied the aforementioned warnings, so I decided to wait a bit and see if further updates would fix the issue. Thankfully, after the most recent batch of updates, the warnings have ceased. So whatever the issue was, it’s fixed now.

    Thread Starter Zebulan Stanphill

    (@zebulan)

    Update: turns out a colleague had disabled the plugin without notifying me, so unfortunately, the issue isn’t fixed after all. We’re trying out different ip-blocker plugins now. Sorry I couldn’t figure out the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Warnings flooding error_log after recent update’ is closed to new replies.