Support » Plugin: Mooberry Book Manager » PHP warnings appearing for plugin

  • version 4.1.13
    WP version 5.2.2
    But we are on a older PHP version – not sure if that is the cauase for these errors throwing up – and its repeated and filling up logs!

    admin error_log
    [25-Jul-2019 08:34:09 UTC] PHP Warning: array_combine(): Both parameters should have an equal number of elements in XXXXXX/plugins/mooberry-book-manager/includes/class-mbm-options.php on line 637
    [25-Jul-2019 08:34:09 UTC] PHP Warning: Invalid argument supplied for foreach() in XXXXXX/plugins/mooberry-book-manager/includes/class-mbm-options.php on line 156

    root error_log
    [24-Jul-2019 16:24:21 UTC] PHP Warning: array_combine(): Both parameters should have an equal number of elements in XXXXXX/plugins/mooberry-book-manager/includes/class-mbm-options.php on line 637
    [24-Jul-2019 16:24:21 UTC] PHP Warning: Invalid argument supplied for foreach() in XXXXXX/plugins/mooberry-book-manager/includes/class-mbm-options.php on line 156

    Could you let me know please

    Thank you
    Sarah

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mooberrydreams

    (@mooberrydreams)

    I will put in an extra check to prevent that error, though I’m not sure how it happens. It seems to indicate something with your list of retailers is not set up correctly. If you go to MBM Settings -> Retailers from your dashboard, do you get any errors?

    If you’d like me to take a look at your site, you can email me at support @ mooberrydreams.com (without the spaces) and create an admin account for me with that email address.

    Thread Starter sarahweb

    (@sarahweb)

    ok checked MBM Settings > Retailers and no errors showed but I did have 5 retailers but only 3 being used 1 2 & 4 so in case that causes issues I have removed the blank ones and I will check errors log in a few hours again – thank you

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP warnings appearing for plugin’ is closed to new replies.