Support » Plugin: Astounding Spam Prevention » PHP warnings

  • Hi,

    So, I’m seeing hundreds of these php warnings in the site error logs:

    [01-Jun-2019 17:47:53 UTC] PHP Warning: Cannot modify header information – headers already sent in /public_html/wp-content/plugins/astounding-spam-prevention/includes/astound-init.php on line 19

    Any idea how to stop these?

    Thanks,

    Del.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author willjenkins

    (@willjenkins)

    Another plugin is running before Astounding Spam and is sending out HTML. Astounding Spam is trying to set a cookie. Astounding spam uses this cookie to find out if a spammer is trying to add a comment or login in a very short time after viewing the page. A human has to check the page, move the mouse to the submit button and press the mouse button down, which takes a couple of seconds.

    You can either

    Check to see which plugin is writing HTML before Astounding spam loads and remove it…

    or

    You can change the priority that plugins load so Astounding Spam loads first…

    or

    You can turn off the quick response test in the Astounding Spam options (easy way). To do this go to the Astounding Spam options page and switch off the Check quick response option under optional settings. This should be turned off by default because it can cause problems when other plugins start adding things to the web page before all the plugins get loaded.

    I hope this helps.

    Keith

    I’ll try turning off the quick response test and see how it goes.

    Shame though… that killed 99.9% of spam registrations with no other custom options on.

    Thanks,

    Del.

    Plugin Author willjenkins

    (@willjenkins)

    I made a change to the way the check session speed is initialized to insure that this won’t happen by mistake. It was buggy the old way. Please update the plugin.

    Keith

    Thank you, Keith.

    I’ve updated the plugin. Will give it a day and let you know if that stopped the errors.

    Thanks,

    Del.

    Sorry Keith… that update didn’t sure the problem.

    So, I’ve switched of the speed check and tweaked other settings, plus added Google reCAPTCHA to login/registration pages (which I really should’ve done a while back, anyway), and all seems to be working well.

    No bot registrations since, but still plenty of rejections in the logs, so the plugin still seems to be doing it’s job very well.

    Many Thanks,

    Del.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.